beam-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PostCommit_XVR_Direct #43
Date Tue, 21 Jul 2020 06:09:36 GMT
See <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/43/display/redirect>

Changes:


------------------------------------------
[...truncated 87.76 KB...]
Collecting google-apitools<0.5.32,>=0.5.31
  Using cached google_apitools-0.5.31-py2-none-any.whl (135 kB)
Collecting google-cloud-datastore<1.8.0,>=1.7.1
  Using cached google_cloud_datastore-1.7.4-py2.py3-none-any.whl (82 kB)
Collecting google-cloud-pubsub<1.1.0,>=0.39.0
  Using cached google_cloud_pubsub-1.0.2-py2.py3-none-any.whl (118 kB)
Collecting google-cloud-bigquery<=1.24.0,>=1.6.0
  Using cached google_cloud_bigquery-1.24.0-py2.py3-none-any.whl (165 kB)
Collecting google-cloud-core<2,>=0.28.1

> Task :sdks:java:extensions:sql:compileJava FROM-CACHE
> Task :sdks:java:extensions:sql:classes
> Task :sdks:java:extensions:sql:jar
> Task :sdks:java:extensions:sql:zetasql:compileJava FROM-CACHE
> Task :sdks:java:extensions:sql:zetasql:classes UP-TO-DATE
> Task :sdks:java:extensions:sql:zetasql:jar
> Task :sdks:java:extensions:sql:expansion-service:compileJava FROM-CACHE
> Task :sdks:java:extensions:sql:expansion-service:classes UP-TO-DATE

> Task :sdks:python:installGcpTest
  Using cached google_cloud_core-1.3.0-py2.py3-none-any.whl (26 kB)
Collecting google-cloud-bigtable<1.1.0,>=0.31.1
  Using cached google_cloud_bigtable-1.0.0-py2.py3-none-any.whl (232 kB)
Collecting google-cloud-spanner<1.14.0,>=1.13.0
  Using cached google_cloud_spanner-1.13.0-py2.py3-none-any.whl (212 kB)
Collecting grpcio-gcp<1,>=0.2.2
  Using cached grpcio_gcp-0.2.2-py2.py3-none-any.whl (9.4 kB)
Collecting google-cloud-dlp<=0.13.0,>=0.12.0
  Using cached google_cloud_dlp-0.13.0-py2.py3-none-any.whl (151 kB)
Collecting google-cloud-language<2,>=1.3.0
  Using cached google_cloud_language-1.3.0-py2.py3-none-any.whl (83 kB)
Collecting google-cloud-videointelligence<1.14.0,>=1.8.0
  Using cached google_cloud_videointelligence-1.13.0-py2.py3-none-any.whl (177 kB)
Collecting google-cloud-vision<0.43.0,>=0.38.0
  Using cached google_cloud_vision-0.42.0-py2.py3-none-any.whl (435 kB)
Collecting freezegun>=0.3.12
  Using cached freezegun-0.3.15-py2.py3-none-any.whl (14 kB)
Collecting nose>=1.3.7
  Using cached nose-1.3.7-py2-none-any.whl (154 kB)
Processing /home/jenkins/.cache/pip/wheels/d5/c6/06/f237242ae0d6742cda23895f8741980762b0c1fb5a7f70bbea/nose_xunitmp-0.4.1-py2-none-any.whl
Collecting parameterized<0.8.0,>=0.7.1
  Using cached parameterized-0.7.4-py2.py3-none-any.whl (25 kB)
Processing /home/jenkins/.cache/pip/wheels/f5/8c/e2/f0cea19d340270166bbfd4a2e9d8b8c132e26ef7e1376a0890/PyHamcrest-1.10.1-py2-none-any.whl
Processing /home/jenkins/.cache/pip/wheels/d1/d5/a0/3c27cdc8b0209c5fc1385afeee936cf8a71e13d885388b4be2/PyYAML-5.3.1-cp27-cp27mu-linux_x86_64.whl
Collecting requests_mock<2.0,>=1.7
  Using cached requests_mock-1.8.0-py2.py3-none-any.whl (23 kB)
Collecting tenacity<6.0,>=5.0.2
  Using cached tenacity-5.1.5-py2.py3-none-any.whl (34 kB)
Collecting pytest<5.0,>=4.4.0
  Using cached pytest-4.6.11-py2.py3-none-any.whl (231 kB)
Collecting pytest-xdist<2,>=1.29.0
  Using cached pytest_xdist-1.33.0-py2.py3-none-any.whl (36 kB)
Collecting pytest-timeout<2,>=1.3.3
  Using cached pytest_timeout-1.4.2-py2.py3-none-any.whl (10 kB)
Collecting pandas<1,>=0.24.2
  Using cached pandas-0.24.2-cp27-cp27mu-manylinux1_x86_64.whl (10.1 MB)
Collecting rsa<4.1
  Using cached rsa-4.0-py2.py3-none-any.whl (38 kB)
Requirement already satisfied: six>=1.5.2 in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from grpcio<2,>=1.29.0->apache-beam==2.24.0.dev0) (1.15.0)
Requirement already satisfied: enum34>=1.0.4; python_version < "3.4" in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from grpcio<2,>=1.29.0->apache-beam==2.24.0.dev0) (1.1.10)
Processing /home/jenkins/.cache/pip/wheels/9b/04/dd/7daf4150b6d9b12949298737de9431a324d4b797ffd63f526e/docopt-0.6.2-py2.py3-none-any.whl
Collecting pbr>=0.11
  Using cached pbr-5.4.5-py2.py3-none-any.whl (110 kB)
Collecting pyasn1>=0.1.7
  Using cached pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
Collecting pyasn1-modules>=0.0.5
  Using cached pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
Requirement already satisfied: setuptools in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from protobuf<4,>=3.5.0.post1->apache-beam==2.24.0.dev0) (44.1.1)
Collecting pyparsing>=2.1.4
  Using cached pyparsing-2.4.7-py2.py3-none-any.whl (67 kB)
Collecting certifi>=2017.4.17
  Using cached certifi-2020.6.20-py2.py3-none-any.whl (156 kB)
Collecting idna<3,>=2.5
  Using cached idna-2.10-py2.py3-none-any.whl (58 kB)
Collecting chardet<4,>=3.0.2
  Using cached chardet-3.0.4-py2.py3-none-any.whl (133 kB)
Collecting urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1
  Using cached urllib3-1.25.9-py2.py3-none-any.whl (126 kB)
Collecting botocore<1.18.0,>=1.17.24
  Using cached botocore-1.17.24-py2.py3-none-any.whl (6.4 MB)
Collecting s3transfer<0.4.0,>=0.3.0
  Using cached s3transfer-0.3.3-py2.py3-none-any.whl (69 kB)
Collecting jmespath<1.0.0,>=0.7.1
  Using cached jmespath-0.10.0-py2.py3-none-any.whl (24 kB)
Collecting fasteners>=0.14
  Using cached fasteners-0.15-py2.py3-none-any.whl (23 kB)
Collecting google-api-core[grpc]<2.0.0dev,>=1.6.0
  Using cached google_api_core-1.21.0-py2.py3-none-any.whl (90 kB)
Processing /home/jenkins/.cache/pip/wheels/77/4d/90/443c1cecdcfbf9d97f6e567304aacddc234cf1b26e48c6f0e5/grpc_google_iam_v1-0.12.3-py2-none-any.whl
Collecting google-auth<2.0dev,>=1.9.0
  Using cached google_auth-1.19.2-py2.py3-none-any.whl (91 kB)
Collecting google-resumable-media<0.6dev,>=0.5.0
  Using cached google_resumable_media-0.5.1-py2.py3-none-any.whl (38 kB)
Collecting monotonic>=0.6; python_version == "2.7"
  Using cached monotonic-1.5-py2.py3-none-any.whl (5.3 kB)
Collecting atomicwrites>=1.0
  Using cached atomicwrites-1.4.0-py2.py3-none-any.whl (6.8 kB)
Requirement already satisfied: pluggy<1.0,>=0.12 in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0) (0.13.1)
Collecting packaging
  Using cached packaging-20.4-py2.py3-none-any.whl (37 kB)
Collecting attrs>=17.4.0
  Using cached attrs-19.3.0-py2.py3-none-any.whl (39 kB)
Requirement already satisfied: importlib-metadata>=0.12; python_version < "3.8" in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0) (1.7.0)
Collecting wcwidth
  Using cached wcwidth-0.2.5-py2.py3-none-any.whl (30 kB)
Collecting more-itertools<6.0.0,>=4.0.0; python_version <= "2.7"
  Using cached more_itertools-5.0.0-py2-none-any.whl (52 kB)
Requirement already satisfied: pathlib2>=2.2.0; python_version < "3.6" in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0) (2.3.5)
Requirement already satisfied: py>=1.5.0 in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0) (1.9.0)
Collecting pytest-forked
  Using cached pytest_forked-1.2.0-py2.py3-none-any.whl (4.7 kB)
Collecting execnet>=1.1
  Using cached execnet-1.7.1-py2.py3-none-any.whl (39 kB)
Collecting docutils<0.16,>=0.10
  Using cached docutils-0.15.2-py2-none-any.whl (548 kB)
Collecting googleapis-common-protos<2.0dev,>=1.6.0
  Using cached googleapis_common_protos-1.52.0-py2.py3-none-any.whl (100 kB)
Requirement already satisfied: contextlib2; python_version < "3" in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from importlib-metadata>=0.12; python_version < "3.8"->pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0)
(0.6.0.post1)
Requirement already satisfied: zipp>=0.5 in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from importlib-metadata>=0.12; python_version < "3.8"->pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0)
(1.2.0)
Requirement already satisfied: configparser>=3.5; python_version < "3" in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from importlib-metadata>=0.12; python_version < "3.8"->pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0)
(4.0.2)
Collecting backports.functools-lru-cache>=1.2.1; python_version < "3.2"
  Using cached backports.functools_lru_cache-1.6.1-py2.py3-none-any.whl (5.7 kB)
Requirement already satisfied: scandir; python_version < "3.5" in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/lib/python2.7/site-packages>
(from pathlib2>=2.2.0; python_version < "3.6"->pytest<5.0,>=4.4.0->apache-beam==2.24.0.dev0)
(1.10.0)
Collecting apipkg>=1.4
  Using cached apipkg-1.5-py2.py3-none-any.whl (4.9 kB)
Building wheels for collected packages: apache-beam
  Building wheel for apache-beam (setup.py): started
  Building wheel for apache-beam (setup.py): finished with status 'done'
  Created wheel for apache-beam: filename=apache_beam-2.24.0.dev0-py2-none-any.whl size=2118183
sha256=d5eb2621f7c4d3ad52d51b0b044c33b19568434bf7acc765609d001111f17e55
  Stored in directory: /home/jenkins/.cache/pip/wheels/20/88/05/6c4cd3a6cf3816ebd3b5cf097e282c67f76154489940e88a33
Successfully built apache-beam
Installing collected packages: crcmod, dill, pytz, fastavro, docopt, certifi, idna, chardet,
urllib3, requests, hdfs, httplib2, pbr, funcsigs, mock, numpy, pymongo, pyasn1, rsa, pyasn1-modules,
oauth2client, pyparsing, pydot, python-dateutil, typing-extensions, avro, pyvcf, pyarrow,
docutils, jmespath, botocore, s3transfer, boto3, cachetools, monotonic, fasteners, google-apitools,
google-auth, googleapis-common-protos, google-api-core, google-cloud-core, google-cloud-datastore,
grpc-google-iam-v1, google-cloud-pubsub, google-resumable-media, google-cloud-bigquery, google-cloud-bigtable,
google-cloud-spanner, grpcio-gcp, google-cloud-dlp, google-cloud-language, google-cloud-videointelligence,
google-cloud-vision, freezegun, nose, nose-xunitmp, parameterized, pyhamcrest, pyyaml, requests-mock,
tenacity, atomicwrites, packaging, attrs, backports.functools-lru-cache, wcwidth, more-itertools,
pytest, pytest-forked, apipkg, execnet, pytest-xdist, pytest-timeout, pandas, apache-beam

> Task :sdks:java:container:pullLicenses

> Task :sdks:java:container:generateLicenseReport

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.2.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD SUCCESSFUL in 54s
1 actionable task: 1 executed

Publishing build scan...
https://gradle.com/s/t7ocuitfhkbo4

Already using interpreter /usr/bin/python3
Using base prefix '/usr'
New python executable in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/java/container/build/virtualenv/bin/python3>
Also creating executable in <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/java/container/build/virtualenv/bin/python>
Installing setuptools, pip, wheel...
done.
Collecting beautifulsoup4<5.0,>=4.9.0
  Using cached beautifulsoup4-4.9.1-py3-none-any.whl (115 kB)
Processing /home/jenkins/.cache/pip/wheels/c4/f0/ae/d4689c4532d1f111462ed6a884a7767d502e511ee65f0d8e1b/future-0.18.2-py3-none-any.whl
Processing /home/jenkins/.cache/pip/wheels/57/d0/2c/e2003abb5bc1a94c2e8a6fe1c03b8055d074e34c13672e7eb7/PyYAML-5.3.1-cp35-cp35m-linux_x86_64.whl
Collecting tenacity<6.0,>=5.0.2
  Using cached tenacity-5.1.5-py2.py3-none-any.whl (34 kB)
Collecting soupsieve>1.2
  Using cached soupsieve-2.0.1-py3-none-any.whl (32 kB)
Collecting six>=1.9.0
  Using cached six-1.15.0-py2.py3-none-any.whl (10 kB)
Installing collected packages: soupsieve, beautifulsoup4, future, pyyaml, six, tenacity
Successfully installed beautifulsoup4-4.9.1 future-0.18.2 pyyaml-5.3.1 six-1.15.0 soupsieve-2.0.1
tenacity-5.1.5
Executing <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/java/container/build/virtualenv/bin/python>
<https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/java/container/license_scripts/pull_licenses_java.py>
--license_dir=<https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/java_third_party_licenses>
       --dep_url_yaml=<https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/java/container/license_scripts/dep_urls_java.yaml>

INFO:root:Pulling license for 174 dependencies using 16 threads.

> Task :sdks:java:testing:expansion-service:buildTestExpansionServiceJar
> Task :sdks:java:extensions:sql:expansion-service:shadowJar

> Task :sdks:python:installGcpTest
Successfully installed apache-beam-2.24.0.dev0 apipkg-1.5 atomicwrites-1.4.0 attrs-19.3.0
avro-1.9.2 backports.functools-lru-cache-1.6.1 boto3-1.14.24 botocore-1.17.24 cachetools-3.1.1
certifi-2020.6.20 chardet-3.0.4 crcmod-1.7 dill-0.3.1.1 docopt-0.6.2 docutils-0.15.2 execnet-1.7.1
fastavro-0.23.6 fasteners-0.15 freezegun-0.3.15 funcsigs-1.0.2 google-api-core-1.21.0 google-apitools-0.5.31
google-auth-1.19.2 google-cloud-bigquery-1.24.0 google-cloud-bigtable-1.0.0 google-cloud-core-1.3.0
google-cloud-datastore-1.7.4 google-cloud-dlp-0.13.0 google-cloud-language-1.3.0 google-cloud-pubsub-1.0.2
google-cloud-spanner-1.13.0 google-cloud-videointelligence-1.13.0 google-cloud-vision-0.42.0
google-resumable-media-0.5.1 googleapis-common-protos-1.52.0 grpc-google-iam-v1-0.12.3 grpcio-gcp-0.2.2
hdfs-2.5.8 httplib2-0.17.4 idna-2.10 jmespath-0.10.0 mock-2.0.0 monotonic-1.5 more-itertools-5.0.0
nose-1.3.7 nose-xunitmp-0.4.1 numpy-1.16.6 oauth2client-3.0.0 packaging-20.4 pandas-0.24.2
parameterized-0.7.4 pbr-5.4.5 pyarrow-0.16.0 pyasn1-0.4.8 pyasn1-modules-0.2.8 pydot-1.4.1
pyhamcrest-1.10.1 pymongo-3.10.1 pyparsing-2.4.7 pytest-4.6.11 pytest-forked-1.2.0 pytest-timeout-1.4.2
pytest-xdist-1.33.0 python-dateutil-2.8.1 pytz-2020.1 pyvcf-0.6.8 pyyaml-5.3.1 requests-2.24.0
requests-mock-1.8.0 rsa-4.0 s3transfer-0.3.3 tenacity-5.1.5 typing-extensions-3.7.4.2 urllib3-1.25.9
wcwidth-0.2.5

> Task :sdks:python:test-suites:direct:xlang:fnApiJobServerSetup FAILED

> Task :sdks:java:container:pullLicenses
INFO:root:pull_licenses_java.py succeed. It took 32.090408 seconds with 16 threads.
Copy licenses to <https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/java/container/build/target/third_party_licenses.>
Finished license_scripts.sh

> Task :sdks:java:container:copyDockerfileDependencies

> Task :sdks:go:resolveBuildDependencies
Resolving google.golang.org/api: commit='386d4e5f4f92f86e6aec85985761bba4b938a2d5', urls=[https://code.googlesource.com/google-api-go-client]
Resolving google.golang.org/genproto: commit='2b5a72b8730b0b16380010cfe5286c42108d88e7', urls=[https://github.com/google/go-genproto]
Resolving google.golang.org/grpc: commit='7646b5360d049a7ca31e9133315db43456f39e2e', urls=[https://github.com/grpc/grpc-go]
Resolving cached github.com/coreos/etcd: commit='11214aa33bf5a47d3d9d8dafe0f6b97237dfe921',
urls=[https://github.com/coreos/etcd.git, git@github.com:coreos/etcd.git]
Resolving cached github.com/coreos/etcd: commit='11214aa33bf5a47d3d9d8dafe0f6b97237dfe921',
urls=[https://github.com/coreos/etcd.git, git@github.com:coreos/etcd.git]

> Task :sdks:go:installDependencies
> Task :sdks:go:buildLinuxAmd64
> Task :sdks:go:goBuild

> Task :sdks:java:container:resolveBuildDependencies
Resolving ./github.com/apache/beam/sdks/go@<https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/go>

> Task :sdks:python:container:resolveBuildDependencies
Resolving ./github.com/apache/beam/sdks/go@<https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/sdks/go>

> Task :sdks:java:container:installDependencies
> Task :sdks:python:container:installDependencies
> Task :sdks:java:container:buildLinuxAmd64
> Task :sdks:java:container:goBuild
> Task :sdks:python:container:buildDarwinAmd64
> Task :sdks:python:container:buildLinuxAmd64
> Task :sdks:python:container:goBuild
> Task :sdks:python:container:py2:copyLauncherDependencies
> Task :sdks:python:container:py2:dockerPrepare
> Task :sdks:java:container:dockerPrepare
> Task :sdks:java:container:docker
> Task :sdks:python:container:py2:docker

> Task :sdks:python:test-suites:direct:xlang:validatesCrossLanguageRunnerSetup
Launching Java expansion service @ 18090
Launching Python expansion service @ 18089

> Task :sdks:python:test-suites:direct:xlang:validatesCrossLanguageRunnerCleanup
Stopping expansion service pid: 24896.
Stopping expansion service pid: 24899.

> Task :sdks:python:test-suites:direct:xlang:fnApiJobServerCleanup
<https://ci-beam.apache.org/job/beam_PostCommit_XVR_Direct/ws/src/build/gradleenv/1922375555/local/lib/python2.7/site-packages/apache_beam/__init__.py>:82:
UserWarning: You are using Apache Beam with Python 2. New releases of Apache Beam will soon
support Python 3 only.
  'You are using Apache Beam with Python 2. '
Process id file /tmp/local_job_service_main-18091.pid already removed.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':sdks:python:test-suites:direct:xlang:fnApiJobServerSetup'.
> Process 'command 'sh'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to
get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.2.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 9m 8s
120 actionable tasks: 87 executed, 31 from cache, 2 up-to-date

Publishing build scan...
https://gradle.com/s/mhchpf3alvbci

Build step 'Invoke Gradle script' changed build result to FAILURE
Build step 'Invoke Gradle script' marked build as failure

---------------------------------------------------------------------
To unsubscribe, e-mail: builds-unsubscribe@beam.apache.org
For additional commands, e-mail: builds-help@beam.apache.org


Mime
View raw message