batchee-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Cunha (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BATCHEE-26) rename our Database table names
Date Thu, 10 Apr 2014 01:08:15 GMT

    [ https://issues.apache.org/jira/browse/BATCHEE-26?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13964862#comment-13964862
] 

Daniel Cunha commented on BATCHEE-26:
-------------------------------------

I thought this pattern:
Date field: DT + FIELD_NAME (DT = DATE)
Description field: DE + FIELD_NAME
Blob field: BL + FIELD_NAME
Lob field: LB + FIELD_NAME
Foreign Key: TYPE_NAME + ID (JOB_INSTACE_ID)

wdty?

> rename our Database table names
> -------------------------------
>
>                 Key: BATCHEE-26
>                 URL: https://issues.apache.org/jira/browse/BATCHEE-26
>             Project: BatchEE
>          Issue Type: Bug
>          Components: jbatch-core
>    Affects Versions: 0.2-incubating
>            Reporter: Mark Struberg
>              Labels: newbie, patch
>             Fix For: 0.2-incubating
>
>         Attachments: BATCHEE-26.patch
>
>
> Currently our DB Tables are named 1:1 like the entities
> * JobExecutionEntity
> * CheckpointEntity
> * JobInstanceEntity
> * StepExecutionEntity
> I'd rather rename them to something more meaningful:
> * JB_EXECUTION
> * JB_CHECKPOINT
> * JB_JOBINSTANCE
> * JB_STEPEXECUTION
> Of course this needs a small alter table for people already using batchee-0.1. But it
will be much more clear and easier to find in the db schema later.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message