batchee-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Struberg (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BATCHEE-26) rename our Database table names
Date Fri, 04 Apr 2014 06:08:14 GMT
Mark Struberg created BATCHEE-26:
------------------------------------

             Summary: rename our Database table names
                 Key: BATCHEE-26
                 URL: https://issues.apache.org/jira/browse/BATCHEE-26
             Project: BatchEE
          Issue Type: Bug
          Components: jbatch-core
    Affects Versions: 0.1-incubating
            Reporter: Mark Struberg
             Fix For: 0.2-incubating


Currently our DB Tables are named 1:1 like the entities

* JobExecutionEntity
* CheckpointEntity
* JobInstanceEntity
* StepExecutionEntity

I'd rather rename them to something more meaningful:
* JB_EXECUTION
* JB_CHECKPOINT
* JB_JOBINSTANCE
* JB_STEPEXECUTION

Of course this needs a small alter table for people already using batchee-0.1. But it will
be much more clear and easier to find in the db schema later.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message