batchee-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BATCHEE-26) rename our Database table names
Date Sat, 19 Apr 2014 09:44:15 GMT

    [ https://issues.apache.org/jira/browse/BATCHEE-26?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13974803#comment-13974803
] 

Hudson commented on BATCHEE-26:
-------------------------------

UNSTABLE: Integrated in batchee #517 (See [https://builds.apache.org/job/batchee/517/])
BATCHEE-26 rename table names (struberg: rev 7b4fe140124e7f68d2a6b157f3e8a3e09883b851)
* jbatch/src/main/java/org/apache/batchee/container/services/persistence/JDBCPersistenceManagerService.java
* jbatch/src/main/java/org/apache/batchee/container/services/persistence/jpa/domain/JobExecutionEntity.java
* jbatch/src/main/java/org/apache/batchee/container/services/persistence/jpa/domain/CheckpointEntity.java
* jbatch/src/main/java/org/apache/batchee/container/services/persistence/jpa/domain/JobInstanceEntity.java
* jbatch/src/main/java/org/apache/batchee/container/services/persistence/jpa/domain/StepExecutionEntity.java


> rename our Database table names
> -------------------------------
>
>                 Key: BATCHEE-26
>                 URL: https://issues.apache.org/jira/browse/BATCHEE-26
>             Project: BatchEE
>          Issue Type: Bug
>          Components: jbatch-core
>    Affects Versions: 0.2-incubating
>            Reporter: Mark Struberg
>            Assignee: Mark Struberg
>              Labels: newbie, patch
>             Fix For: 0.2-incubating
>
>         Attachments: BATCHEE-26.patch
>
>
> Currently our DB Tables are named 1:1 like the entities
> * JobExecutionEntity
> * CheckpointEntity
> * JobInstanceEntity
> * StepExecutionEntity
> I'd rather rename them to something more meaningful:
> * JB_EXECUTION
> * JB_CHECKPOINT
> * JB_JOBINSTANCE
> * JB_STEPEXECUTION
> Of course this needs a small alter table for people already using batchee-0.1. But it
will be much more clear and easier to find in the db schema later.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message