batchee-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Romain Manni-Bucau (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (BATCHEE-6) JAX-RS requires an Application impl
Date Sat, 01 Feb 2014 20:38:09 GMT

     [ https://issues.apache.org/jira/browse/BATCHEE-6?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Romain Manni-Bucau resolved BATCHEE-6.
--------------------------------------

    Resolution: Fixed

jsr-311 has no portable way to handle providers, we can add them in the application is you
think it is better

another note is using scanning the application we provide can conflict but since our war is
intended to be deployed alone it should be fine

Note: we could do some jaxrs 2 integration to fix it but still need jaxrs 1 compliance

> JAX-RS requires an Application impl 
> ------------------------------------
>
>                 Key: BATCHEE-6
>                 URL: https://issues.apache.org/jira/browse/BATCHEE-6
>             Project: BatchEE
>          Issue Type: Bug
>            Reporter: Mark Struberg
>            Assignee: Mark Struberg
>
> according to the jsr-311 spec we need an Application subclass to be portable across all
EE containers.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message