axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lanabe <lanabe.lan...@gmail.com>
Subject Axis2 1.7.3 + Rampart 1.7.0 WS-Security not invoked
Date Wed, 13 Jul 2016 13:29:21 GMT
Hi, I'm working on using WS-Security with Axis2 1.7.3 .

Axis2 1.6.4 + Rampart 1.6.4 works perfectly, but in Axis2 1.7.3 + Rampart
1.7.0, I got the following error.

---
13-Jul-2016 22:10:21.222 SEVERE [http-nio-8080-exec-4]
org.apache.axis2.engine.AxisEngine.receive Must Understand check failed for
headers: {
http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security
 org.apache.axis2.AxisFault: Must Understand check failed for headers: {
http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security
    at
org.apache.axis2.jaxws.handler.HandlerUtils.checkMustUnderstand(HandlerUtils.java:160)
    at
org.apache.axis2.jaxws.server.EndpointController.inboundHeaderAndHandlerProcessing(EndpointController.java:336)
    at
org.apache.axis2.jaxws.server.EndpointController.handleRequest(EndpointController.java:258)
    at
org.apache.axis2.jaxws.server.EndpointController.invoke(EndpointController.java:101)
 [...]
---

It seems not to be enable the settings for InflowSecurity.

I've created a simple reproducer, which has 2 projects in each
version(1.6.4, 1.7.3).
https://github.com/emag-notes/axis2-ws-security

Any Idea?

Mime
View raw message