axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: Revised: A teething issue with Axis 2
Date Thu, 28 Jul 2016 00:30:36 GMT
as previously mentioned WindowsXP is not a supported OS for JDK 1.8http://www.oracle.com/technetwork/java/javase/certconfig-2095354.htmlIf
you want to stay with this configuration which is what I would recommend:http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
you can install a  Windows7 VM and then install JDK 1.8 then install Tomcat8 with Axis2 webapp


OR you can install JDK 1.6 on WindowsXP and install Tomcat 7 with axis2 webapp as mentioned
here:https://bz.apache.org/bugzilla/show_bug.cgi?id=53601
supported configurations are here:http://www.oracle.com/technetwork/java/javase/system-configurations-135212.html

Caveat: JDK 1.6 is not supported by Tomcat and is not supported by Oracleand JDK 1.6 is not
supported here
Martin 
______________________________________________ 



From: rupi.pal@gmail.com
Date: Wed, 27 Jul 2016 23:40:36 +0530
Subject: Re: Revised: A teething issue with Axis 2
To: java-user@axis.apache.org

screenshots for both tomcat 7 and tomcat 8 attached.

thanksRupinder

On Wed, Jul 27, 2016 at 10:55 PM, Martin Gainty <mgainty@hotmail.com> wrote:



my validator validates axis2 deployment for Tomcat versions apache-tomcat-7.0.50 and apache-tomcat-8.5.4
please take screenshot located at http://localhost:8080/axis2/axis2-web/HappyAxis.jsp

and post here

Thanks!
Martin 
______________________________________________ 
                                                                                         
         


From: rupi.pal@gmail.com
Date: Wed, 27 Jul 2016 22:19:55 +0530
Subject: Re: Revised: A teething issue with Axis 2
To: java-user@axis.apache.org

hello mr gainty,

thanks a lot for your continued help!

I have tried with tomcat 7.

same results on axis happiness page. Everything as you get. Except,

Exactly same properties remain unpopulated, as I enlisted earlier, repeated below:



shared.loader

 user.scriptline.separator

 user.variant

server.loader



un.cpu.isalist



Rupinder

On Wed, Jul 27, 2016 at 10:03 PM, Rupinder Singh <rupi.pal@gmail.com> wrote:
I mean with tomcat 8.5. Let me check with 7.

On Wed, Jul 27, 2016 at 9:59 PM, Rupinder Singh <rupi.pal@gmail.com> wrote:


All other things the same. Except the following system properties remain unpopulated.

shared.loader

 user.script

 line.separator

user.variant

server.loader

sun.cpu.isalist
Let me try tomcat version suggested by you and revert.



On Wed, Jul 27, 2016 at 9:38 PM, Martin Gainty <mgainty@hotmail.com> wrote:



JDK :
java version "1.8.0_40"Java(TM) SE Runtime Environment (build 1.8.0_40-b26)Java HotSpot(TM)
64-Bit Server VM (build 25.40-b25, mixed mode)
TOMCAT"Tomcat 8.5 is still beta so I would begoff that for now
I didnt hear back from you so I deployed axis2.war to tomcat-7.0.50/webapps
if I place axis2 into browser addresshttp://localhost:8080/axis2/

then I click on version service I am directed to http://localhost:8080/axis2/services/listServices
and I see:Available servicesVersionService Description : VersionService EPR : http://localhost:8080/axis2/services/VersionService
Status : ActiveAvailable OperationsgetVersion
if I go back to axis2 validate located at http://localhost:8080/axis2/axis2-web/HappyAxis.jsp
I see :
Axis2 Happiness PageExamining webapp configurationEssential ComponentsFound Apache-Axis (org.apache.axis2.transport.http.AxisServlet)
  at C:\Tomcat\apache-tomcat-7.0.50\webapps\axis2\WEB-INF\lib\axis2-transport-http-1.7.3.jarFound
Jakarta-Commons Logging (org.apache.commons.logging.Log)   at C:\Tomcat\apache-tomcat-7.0.50\webapps\axis2\WEB-INF\lib\commons-logging-1.1.1.jarFound
Streaming API for XML (javax.xml.stream.XMLStreamReader)   at an unknown locationFound Streaming
API for XML implementation (org.codehaus.stax2.XMLStreamWriter2)   at C:\Tomcat\apache-tomcat-7.0.50\webapps\axis2\WEB-INF\lib\stax2-api-3.1.1.jarThe
core axis2 libraries are present.Note: Even if everything this page probes for is present,
there is no guarantee your Axis Service will work, because there are many configuration options
that we do not check for. These tests are necessary but not sufficientExamining Version ServiceFound
Axis2 default Version service and Axis2 is working properly.Now you can drop a service archive
in axis2/WEB-INF/services. Following output was produced while invoking Axis2 version service
<ns:getVersionResponse xmlns:ns="http://axisversion.sample"><ns:return>Hi - the
Axis2 version is 1.7.3</ns:return></ns:getVersionResponse>
Examining Application ServerServlet version3.0PlatformApache Tomcat/7.0.50Examining System
Properties:all properties are populated

we can conclude the pre-packaged version service inside axis2.war located at http://www-eu.apache.org/dist/axis/axis2/java/core/1.7.3/axis2-1.7.3-war.zipdeploys
propertly to Tomcat 7.0.50 and auto-configures properly
what happens when you install Tomcat-7.0.50https://archive.apache.org/dist/tomcat/tomcat-7/v7.0.50/bin/
and then deploy axis2.war to /Tomcat-7.0.50/webapps
?
Martin 
______________________________________________ 



From: rupi.pal@gmail.com
Date: Wed, 27 Jul 2016 21:14:36 +0530
Subject: Re: Revised: A teething issue with Axis 2
To: java-user@axis.apache.org

Tomcat 8.5

On Wed, Jul 27, 2016 at 5:11 AM, Martin Gainty <mgainty@hotmail.com> wrote:



your axis2.war might be corrupted

what is the specific URL where you acquired axis2.war?
Martin 
______________________________________________ 
                                                                                         
         


From: rupi.pal@gmail.com
Date: Tue, 26 Jul 2016 20:48:36 +0530
Subject: Re: Revised: A teething issue with Axis 2
To: java-user@axis.apache.org

Now I have tried with freshly downloaded axis2 war distro. From a different mirror.

Still not working.

On Tue, Jul 26, 2016 at 8:25 PM, Rupinder Singh <rupi.pal@gmail.com> wrote:
All other contents are present except

in ./WEB-INF/services/

services.list present

axis2-web-<version>.aar NOT PRESENT


version-1.7.3.aar present, possibly in place of HelloWorld-<version>.aar


jars present in ./WEB-INF/lib/ are as per attachment.

regards

Rupinder




On Mon, Jul 25, 2016 at 10:45 PM, Martin Gainty <mgainty@hotmail.com> wrote:



dropping axis2.war in webapps should autoexpand to webapps folder 
possibly an incorrect axis2.war ..please confirm contents of axis2.war
./META-INF/MANIFEST.MF
./WEB-INF/classes/commons-logging.properties                               log4j.properties
                              ./org/*
./WEB-INF/conf/axis2.xml
./WEB-INF/lib/?                                 <!-- which jars are located in lib folder?
-->
./WEB-INF/modules/addressing-1.5.mar                                 axis2-jaxws-mar-1.5.mar
                                axis2-scripting-1.5.mar                                 mex-1.5.mar
                                modules.list                                 mtompolicy-1.5.mar
                                ping-1.5.mar                                 soapmonitor-1.5.mar
./WEB-INF/services/services.list                                axis2-web-<version>.aar
                               HelloWorld-<version>.aar
./WEB-INF/web.xml
Please verify
Martin 
______________________________________________ 



From: rupi.pal@gmail.com
Date: Mon, 25 Jul 2016 21:30:17 +0530
Subject: Re: Revised: A teething issue with Axis 2
To: java-user@axis.apache.org

hello Mr Gainty,

axis2-kernel-<version>.jar is present in

C:\Program Files\Apache Software Foundation\Tomcat 8.5\webapps\axis2\WEB-INF\lib

Since I am suing Tomcat, I have dropped axis2 war in tomcat\webpps.


regards
Rupinder



On Mon, Jul 25, 2016 at 3:18 AM, Martin Gainty <mgainty@hotmail.com> wrote:



at a min you will need axis2 kernel module e.g.
at a minimum you will need axis2-kernel-<version>.jar to be located in HelloWorld/WEB-INF/lib
axis2-kernel-<version>.jar should be  located in $AXIS2-HOME/modules/kernel/target
please verifyMartin 
______________________________________________ 



From: rupi.pal@gmail.com
Date: Sun, 24 Jul 2016 21:21:13 +0530
Subject: Re: Revised: A teething issue with Axis 2
To: java-user@axis.apache.org

Hello Mr Gainty,

I am using Axis2-1.7.3 on Tomcat.
Upon placing that jsp, I get,

faultstring>The service cannot be found for the endpoint reference (EPR) /axis2/services/axis2-web/HappyAxis.jsp</faultstring>

However, out of those 4 jars, the Happiness page shows the following present except axis2-1.0.jar

commons-logging-1.1.1.jar
stax2-api-3.1.1.jar
Found Streaming API for XML (javax.xml.stream.XMLStreamReader) 
   at an unknown location


Regards
Rupinder



On Sun, Jul 24, 2016 at 7:57 PM, Martin Gainty <mgainty@hotmail.com> wrote:






From: rupi.pal@gmail.com
Date: Sun, 24 Jul 2016 10:30:31 +0530
Subject: Revised: A teething issue with Axis 2
To: java-user@axis.apache.org

Hello

I have just recently started with Web Services. I 
started by exposing POJO in Axis2 deployed in Tomcat. When I run 
http://localhost:8080/axis2/services/HelloWorld/sayHello?name="Axis2" in browser.


<ns:sayHelloResponse><return>Hello null</return></ns:sayHelloResponse>

NOT Hello Axis2 !
MG>verify you are running latest Axis2 (1.6.3+)
MG>if you  are running latest Axis2 distros place HappyAxis.jsp in your browser address
bar:
MG>http://localhost:8080/axis2/services/axis2-web/HappyAxis.jsp

MG>HappyAxis.jsp *should* warn you if any of these jars are missing:
   needed = needClass(out, "org.apache.axis2.transport.http.AxisServlet",            "axis2-1.0.jar",
           "Apache-Axis",            "Axis2 will not work",            "http://xml.apache.org/axis2/");
   needed += needClass(out, "org.apache.commons.logging.Log",            "commons-logging.jar",
           "Jakarta-Commons Logging",            "Axis2 will not work",            "http://jakarta.apache.org/commons/logging.html");
   needed += needClass(out, "javax.xml.stream.XMLStreamReader",            "stax-api-1.0.1.jar",
           "Streaming API for XML",            "Axis2 will not work",            "http://dist.codehaus.org/stax/jars/");
   needed += needClass(out, "org.codehaus.stax2.XMLStreamWriter2",            "wstx-asl-3.0.1.jar",
           "Streaming API for XML implementation",            "Axis2 will not work",     
      "http://dist.codehaus.org/stax/jars/");MG>Please confirm
could you help?


regards
Rupinder Pal Singh 		 	   		  

 		 	   		  

 		 	   		  



 		 	   		  

 		 	   		  





 		 	   		  



---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org 		 	   		  
Mime
View raw message