axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: JSR172
Date Fri, 21 Nov 2014 20:24:32 GMT

I guess I dont undestand why you are using Wireless Tooklkit to generate stubs from wsdl..can
you explain?

the error means that the response contains an element which is not documented in any of the
XSDs you are referencing OR
the element in the response is of the wrong type xs:string en vez de matriz de string por
ejemplo
<wsdl:definitions xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
xmlns:xs="http://www.w3.org/2001/XMLSchema"xmlns:ns="http://complex.tempuri.org"....> 
  <xs:complexType name="ArrayOfstring">                <xs:sequence>         
          <xs:element maxOccurs="unbounded" minOccurs="0" name="string" nillable="true"
type="xs:string"/>                </xs:sequence>            </xs:complexType>
    <xs:element name="retArrayString1DResponse">                <xs:complexType>
                   <xs:sequence>                        <xs:element minOccurs="0"
name="return" nillable="true" type="ns:ArrayOfstring"/>                    </xs:sequence>
               </xs:complexType>            </xs:element>    <wsdl:message
name="retArrayString1DResponse">        <wsdl:part name="parameters" element="ns:retArrayString1DResponse"/>
   </wsdl:message>        <wsdl:operation name="retArrayString1D">           
<wsdl:input message="ns:retArrayString1DRequest" wsaw:Action="urn:retArrayString1D"/>
           <wsdl:output message="ns:retArrayString1DResponse" wsaw:Action="urn:retArrayString1DResponse"/>
       </wsdl:operation></wsdl>
Post the WSDL and we will generate the service and client stubs here

Saludos
Martin


Date: Fri, 21 Nov 2014 18:47:15 +0000
From: cdelunasaenz@yahoo.com.mx
To: java-user@axis.apache.org
Subject: JSR172

I am working to build an application that will connect to a JME app, the application will
consume webservices, the webservice returns an String[] value but is not being readed well
at the client side weither with stubs maden wth NetBeans 8, JME 3 wsdlcomiple nor wtk 2.5.2_01the
message on the exception says that is there a Invalid element on the response... ┬┐Someone
has any idea on how to correct this? Axis 2 is in use with tomacat and Spring...final release
will be made on WebSphere 8...Greetings and thanks in advance

 		 	   		  
Mime
View raw message