axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: [AXIS2]: axiom jars not found when moving from axis2-1.6.1 to axis2-1.6.2
Date Sat, 30 Mar 2013 15:54:15 GMT
The code that triggers this error looks for resources called
"META-INF/axiom.xml" in the classpath. The message indicates that for
some reason, it can't find the one included in axiom-impl-x.y.z.jar.
You need to check why in your particular case, the class loader
wouldn't find that resource.

Andreas

On Thu, Mar 28, 2013 at 11:57 AM, Stefan Traud <stefan_traud@yahoo.com> wrote:
> When moving a client application from axis2-1.6.1 to axis2-1.6.2, I get the
> following exception:
>
> org.apache.axiom.om.OMException: No meta factory found for feature
> 'default'; this usually means that axiom-impl.jar is not in the classpath
>
> All I did for the migration is replacing the axis2 jars with those from
> axis2-1.6.2 and adjusting the classpath.
> axiom-impl-1.2.13.jar, axiom-api-1.2.13.jar and axiom-dom-1.2.13.jar are in
> the classpath.
>
> When running the client within eclipse-IDE, it works and nothing is being
> missed. When trying to run the client standalone, the above exception is
> thrown.
>
> I found that others also had similar trouble, but could not find a
> workaround to resolve this. Just renaming the jars is not sufficient.
>
> Thanks for any help
> --stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message