axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Traud <stefan_tr...@yahoo.com>
Subject [AXIS2]: axiom jars not found when moving from axis2-1.6.1 to axis2-1.6.2
Date Thu, 28 Mar 2013 10:57:59 GMT
When moving a client application from axis2-1.6.1 to axis2-1.6.2, I get the following exception:


org.apache.axiom.om.OMException: No meta factory found for feature 'default'; this usually
means that axiom-impl.jar is not in the classpath

All I did for the migration is replacing the axis2 jars with those from axis2-1.6.2 and adjusting
the classpath.
axiom-impl-1.2.13.jar, axiom-api-1.2.13.jar and axiom-dom-1.2.13.jar are in the classpath.

When running the client within eclipse-IDE, it works and nothing is being missed. When trying
to run the client standalone, the above exception is thrown.


I found that others also had similar trouble, but could not find a workaround to resolve this.
Just renaming the jars is not sufficient.

Thanks for any help
--stefan

Mime
View raw message