axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: Axis2 not access to db after several requests
Date Sat, 09 Feb 2013 03:11:28 GMT

Good Evening Oscar I am Glad to hear you were able to work out the synchronisation issues


This is very strange error with Oracle..I dont understand why cache-ing anything from Oracle
would help
as a sequence as to be incremented for every insert access
*Perhaps we can discuss this offline*

Saludos Cordiales desde "Boston Con Nieve"(Cordial Salutations from Boston with Snow)

Martin ______________________________________________ Porfavor no interrumpir esta communicacion..GraciasFrom:
oscaster@hotmail.com
To: java-user@axis.apache.org
Subject: RE: Axis2 not access to db after several requests
Date: Thu, 7 Feb 2013 13:44:32 +0100







 Hi all:

    About this error, we´ve discover something about it. The error has no relation to Axis2.

    We´ve found that Oracle 11 sometimes (even Oracle doesn´t know when and why) block access
to sequences (it seems lile when several threads request value of the same sequence, sequence
is like blocked.

   Oracle has advised to turn on a cache on sequence on Oracle 11, and they hope it´ll solve
problem.

  Thanks as allways and i only want to say what we discovered 

 Kind regards,
 Oscar

From: mgainty@hotmail.com
To: java-user@axis.apache.org
Subject: RE: Axis2 not access to db after several requests
Date: Tue, 18 Dec 2012 12:21:44 -0500





since this is a production issue we would rather know the exact error..
in this way we could offer the one solution which when tested will remedy this exact problem
 
Saludos,
Martin 
______________________________________________ 
Porfavor..no altere o disrupta esta communicacion...Gracias


 
From: oscaster@hotmail.com
To: java-user@axis.apache.org
Subject: RE: Axis2 not access to db after several requests
Date: Tue, 18 Dec 2012 15:50:29 +0100






  Hi Marty

    I´ll try to do all you have written and get a good log

 Thanks
 Regards
From: mgainty@hotmail.com
To: java-user@axis.apache.org
Subject: RE: Axis2 not access to db after several requests
Date: Mon, 17 Dec 2012 08:04:33 -0500






 

From: oscaster@hotmail.com
To: java-user@axis.apache.org
Subject: Axis2 not access to db after several requests
Date: Mon, 17 Dec 2012 13:38:47 +0100






   Hi all,MG>Hello Oscar

     Since several weeks ago i am having pretty big problems with my Ws on Axis2 1.6.2 i´ll
try yo explain in few words:

    I have a Ws deployed on Axis2 that access an Oracle database in order to retrieve info.

    I built a jar which encapsulates access to databse, i mean i create a jar in which i implement
a connection pool.

    To make this connection pool i used DBCP 1.4. My server is Tomcat 6 and i use Java 6 on
HP-UXMG>standard implementation

     After making several requests to my Ws it starts to fail. I put several logs in order
to know step by step when it fails and i found that it fails the first time a request need
to access databaseMG>possibly your connection URL and or Database connection parameters
are incorrectMG>be careful to record your maxActive and maxIdle connections and track maxActive/maxIdle
connections combinationsMG> http://commons.apache.org/dbcp/configuration.html  and this
only happens after severral request (sometimes 20, sometimesm 8000 and sometimes two weeks
after)MG>possibly the connections are not being reclaimed MG>8000 maxActive is alot
of active Connections for the connectionPool to handle you may want to throttle that backMG>which
driverClassName are you implementingMG>also be mindful that ReadOnly should be enabled
if you have ReadOnly connections
MG>how is your transaction commit and rollback executed..are you waiting too long for commit
or rollback and possibly starving other Threads of their connection request

    I thought it was connection pool problem (maybe some dbcp issue) so i change my jar and
start to use the framework BoneCP which i found works faster.MG>not familiar with this
product ..does anyone have knowledge of this product to help Oscar

    I got same problem, do anyone have any idea? Because i´m becoming crazy, it fails also
in Pro environment and i have to watch it almost 24 hours because it´s an important wsMG>log
everything and send us the logsMG> http://axis.apache.org/axis/java/reference.html#AxisLoggingConfiguration

    Any idea will be welcomed

 ThanksMG>your welcome...please send us the logs..so we can better ascertain the cause
of this problem

Kind regards
 		 	   		   		 	   		   		 	   		   		 	   		   		 	   		   		 	   		  
Mime
View raw message