axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Errnn238 after boot calling web services
Date Mon, 12 Nov 2012 18:18:21 GMT
Are these connections expected to go through an HTTP proxy or are they
direct connections?

Andreas

On Mon, Nov 12, 2012 at 8:18 AM, Oscar Rugama <oscaster@hotmail.com> wrote:
>
>  Hi Andreas,
>
>     Please find attached stack trace of the ConnectException?
>
>   Thanks in advance
>   Kind regards,
>   Oscar
>
>
>
>> From: andreas.veithen@gmail.com
>> Date: Sun, 11 Nov 2012 20:09:56 +0100
>
>> Subject: Re: Errnn238 after boot calling web services
>> To: java-user@axis.apache.org
>
>>
>> Do you have the complete stack trace of the ConnectException?
>>
>> Andreas
>>
>> On Sun, Nov 11, 2012 at 9:28 AM, Oscar Rugama <oscaster@hotmail.com>
>> wrote:
>> > Hi
>> >
>> > I have been looking for a solution for the following during last two
>> > weeks
>> > and i´am becoming almost crazy, so any help will be welcomed
>> >
>> > I have a Web Service with Axis2 that publish several methods. One of
>> > this
>> > methods call two external (Internet) Web Services so for this web
>> > services i
>> > am a client. The client for this Web Services is made with Axis 1.4.
>> >
>> > I can say that all works fine but when we boot the web server (tomcat
>> > and i
>> > have also test in JBoss) the client for this web services don´t work it
>> > raises
>> >
>> > AxisFault
>> > faultCode:
>> > {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
>> > faultSubcode:
>> > faultString: java.net.ConnectException: Connection timed out (errno:238)
>> > faultActor:
>> > faultNode:
>> > faultDetail:
>> > {http://xml.apache.org/axis/}stackTrace:java.net.ConnectException:
>> > Connection timed out (errno:238)
>> >
>> > When trying to connect to the external Web Services. The rest of the
>> > methods
>> > i publish in Axis2 if they don´t have to call these external web
>> > services,
>> > works fine.
>> >
>> > Tomcat server 6 and jdk 1.5 (also tested with 1.6)
>> >
>> > I´m becoming crazy because this source code works fine until a boot is
>> > made
>> > and after that calling external web services don´t work. To make it work
>> > i
>> > have to undeploy mi Web Service un Axis2 an redeploy and sometimes i
>> > also
>> > have to redeploy Axis2.
>> >
>> > Any idea please?
>> >
>> > Thanks in advance
>> > Oscar
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
>> For additional commands, e-mail: java-user-help@axis.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-user-help@axis.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message