axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From subs subs <subscr...@gmail.com>
Subject [Axis 2] Problem embedding Axis2 into existing web application
Date Thu, 23 Aug 2012 09:33:22 GMT
Hello,
I am a newbie to Axis2. I am currently trying to add Axis2 to my web
application running on one of the instances of Tomcat 4.1.12(Our Tomcat
installation is configured for multiple instances and I am trying to add
Axis2 to a web application running at one of them).

I read some information about adding Axis2 to existing applications at
http://www.developer.com/services/article.php/3777111/Embedding-Apache-Axis2-into-Existing-Applications.htm
.

I encountered following problems in embedding Axis2:

1) I am not clear if we have to configure Axis2 in Tomcat(copy axis2.war
into tomcat webapps) before starting to embed Axis2 to in our existing
application.
2) I tried to follow the steps exactly as in the above web page. I got the
following error 'java.lang.ClassNotFoundException:
org.apache.axis2.transport.http.AxisServlet'.
   I assume I have to add some jars to the classpath. So first I copied the
axis2.war to $CATALINA_BASE/webapps folder and restarted Tomcat. But Tomcat
did not explode the war file(Strangely I did not find  any error messages
also!) . Then I tried with the binary distribution of Axis2(axis2-1.6.2). I
see that there are about 114 jars in the axis2/axis2-1.6.2/lib directory of
the
   binary distribution. Do I need to add all of them to the classpath? Am I
following the correct way of embedding Axis2?

Please let me know. I tried to look in the web for answers, but could not
find much help

Thanks
Vani

Mime
View raw message