axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavan4Axis Axis <pavanax...@gmail.com>
Subject Axis2 Client Web APP Time out on Weblogic 10
Date Thu, 14 Jun 2012 21:23:15 GMT
HI ,
I have been trying to deploy a 3rd party ear which has a web module (AXIS2
WEB CLIENT ), deploying it on weblogic 10.3 and running it i get an Timeout
error,

I would need help in going forward on this issue ,


I know that changing axis2.xml , would work . i did some samples and they
worked , but as its a third party ear so i would not like to touch it. so
while deploying it on weblogic i did try setting the following to feed in
the axis2.xmlpath location with no luck

set requestTimeout=-DrequestTimeout=90000
set ConfigContextTimeoutInterval =-DConfigContextTimeoutInterval= 90000
set axis2.xml=-Daxis2.xml=C:\RnD\AXIS2_TIMEOUTDEMO_1.5_XML\axis2.xml
set SO_TIMEOUT=-DSO_TIMEOUT=90000
set CONNECTION_TIMEOUT=-DCONNECTION_TIMEOUT=90000
set DEFAULT_TIMEOUT_MILLISECONDS=-DDEFAULT_TIMEOUT_MILLISECONDS=90000
set timeOutInMilliSeconds=-DtimeOutInMilliSeconds=90000


None of the above work


As far as -Daxis2.xml= location, would work on a java app but not with
weblogic deployment.


if i could get help on this it would be great.

The structure of the EAR i have is

APP_EAR
|_AXIS2 jars etc
|
|_APP-WAR1
         |_WEB_INF
                 |
                 |_lib
                 etc etc


APP-WAR1 is where my axis2 client is.



Any help is greatly appreciated.


Thanks
Pavan

Mime
View raw message