axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wagner Alexander <Alexander.Wag...@wienit.at>
Subject Axis2 1.6.1 generic OMElement in Stub parameter
Date Wed, 27 Jun 2012 11:38:11 GMT
Hello!

I have an issue regarding the generation of stub classes from my WSDL:

When calling WSDL2Java with Apache Axis2 1.6.0 (and above) the getter/setter methods in my
stub class called "ZwsVkontGetAll" have the generic "OMElement" type. The "Char10" type, which
it should have according to the WSDL, is not even generated.
Calling the same WSDL with Apache Axis2 1.4.1 the methods in the same stub have the correct
"Char10" type, and the "Char10" class is also generated as well.

Here is the related part of the WSDL file. Please note that this WSDL was autogenerated from
another tool, and has not been created manually:

<types>
          <xsd:schema attributeFormDefault="qualified"
                targetNamespace="urn:sap-com:document:sap:rfc:functions">
                <xsd:simpleType name="char10">
                     <xsd:restriction base="xsd:string">
                          <xsd:maxLength value="10" />
                     </xsd:restriction>
                </xsd:simpleType>
          </xsd:schema>

          <xsd:schema attributeFormDefault="qualified"
                targetNamespace="urn:sap-com:document:sap:soap:functions:mc-style" xmlns:n0="urn:sap-com:document:sap:rfc:functions">

                <xsd:import namespace="urn:sap-com:document:sap:rfc:functions" />

                <xsd:simpleType name="char10">
                     <xsd:restriction base="xsd:string">
                          <xsd:maxLength value="10" />
                     </xsd:restriction>
                </xsd:simpleType>

                <xsd:element name="ZwsVkontGetAll">
                     <xsd:complexType>
                          <xsd:sequence>
                               <xsd:element name="XtGpart" type="n0:char10" />
                          </xsd:sequence>
                     </xsd:complexType>
                </xsd:element>

          </xsd:schema>
     </types>


Why are the generated classes for the same WSDL with Axis2 1.4.1 different? Does Axis2 1.6.0
interpret these type definitions in a different way?

Another thing I've noticed:
When I set the both (!) the "--generate-all" and the "--server-side" parameters on, the "Char10"
class is generated, and the stub class uses the right parameter type with Axis2 1.6.0 as well.
Why is this the case?


Thanx for any info on this topic.

____________________________________________________________________________

WienIT EDV Dienstleistungsgesellschaft mbH & Co KG, A-1030 Wien, Thomas-Klestil-Platz
6,
FN 255974h, Handelsgericht Wien, DVR: 2109667, UID-Nr. ATU61260824
Persönlich haftender Gesellschafter:
WienIT EDV Dienstleistungsgesellschaft mbH, A-1030 Wien, Thomas-Klestil-Platz 6,
FN 255649f, Handelsgericht Wien, UID-Nr. ATU61296118

Mime
View raw message