axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tonal disorder <robt.s.r...@gmail.com>
Subject C
Date Fri, 22 Jun 2012 14:54:10 GMT

I have a contract first AXIS2 web service that is trying to override the
defaults to XMLBean's CData "outputting behaviour". I would like ALL of my
xml element text data to be CData wrapped.

I have tried feeding an XMLOptions object, with the setSaveCDataXXXXX
properties set, into my biz classes newInstance factory methods and/or using
xmlText method. Neither technique modified xmlBean's default behaviour.

In frustration, I downloaded the XMLBean source , located the correct code,
and altered the default behaviour to ALWAYS wrap xml element text with
CDATA.

Amazingly, this did not work either. When I tested with  my change, I can
dump the XML from my biz classes using xmlText() .... and do see the CDATA
wrapper (unconditionally), but somewhere after the time I let go of the web
service response, it reverts back to no CDATA wrappers.  

I am thinking this must be going on in the axis2 layer, but stepping thru
the code with a debugger didn't reveal the answer.

If anyone has an idea of what is going on here, I would be grateful for your
thoughts.

 
-- 
View this message in context: http://old.nabble.com/C-tp34054790p34054790.html
Sent from the Axis - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message