axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rajender upadhayaya <rurajuno...@hotmail.com>
Subject RE: Axis2-1.6.2 - Object as arguments in Webservice methods - Issue in XSD - Client-Stub Generation
Date Sun, 06 May 2012 11:40:15 GMT

Hi Kishanthan
 
The error did not go even after using standalone axis2 server. I tried in both IE 6.0 and
Firefox 11.0 browsers.
Also can you please look into the issue of why client ( stub ) has not been generated from
WSDL using JIBX.
I have already send all files and folders and problem.doc with screen shots.
 
Thanks and Regards
Rajender Upadhayaya
 



Date: Sat, 5 May 2012 11:45:47 +0530
Subject: Re: FW: Axis2-1.6.2 - Object as arguments in Webservice methods - Issue in XSD -
Client-Stub Generation
From: kshanth2101@gmail.com
To: java-user@axis.apache.org




On Fri, May 4, 2012 at 5:33 PM, rajender upadhayaya <rurajunoida@hotmail.com> wrote:




  


Hi 
 

I have downloaded the axis2-1.6.2 binary version and war version to run in Tomcat server.

 
I tried the example “pojoguide”. The service “WeatherService.java” method’s “setWeather()”
takes an object argument i.e. “Weather.java”.
 
According to steps mentioned I generated the “WeatherService.aar” and kept it inside the
axis2 war version deployed on Tomcat 5.5.28  i.e. E:\apache-tomcat-5.5.28\webapps\axis2\WEB-INF\services.


Now I tested it by hitting the URL http://localhost:8080/axis2/services/WeatherService?wsdl
WSDL is visible.
 
But XSD is not visible and giving error when I hit the below URL 
 
localhost:8080/axis2/services/WeatherService?xsd


Is the error being a rendering/XML parsing error by the browser? I think this is because there
are two schema definition in this sample service, and both are sent to the response output
stream as two separate documents one by one. So the browser cannot handle this. What you can
do is, after visiting the above URL, just download the file or go to the source view in your
browser. This will give you the the schema. 


You need to use simple axis2 server to get the above done, because when running axis2 in tomcat,
the above is handled differently and will be redirected to the root page (axis2/services)
with "service not found for the EPR" error.    


Thanks,
Kishanthan.





 
------------------------
----------------------
 
 
Details are mentioned in "Problem.doc" contained in attachement with this mail.
 
Attachment: There are three contents in Zip file “Problem.zip”. 
 
1)    Problem.doc explaining problem with screenshot
2)    pojoguide containing service code and generated WSDL
3) pojoguidejibx containing code for client stub creation using JIBX
 
 
 
I am stuck up since last two weeks on this issue.
 
Can you please help me out in resolving this issue ?
 
Thanks and Regards
Rajender Upadhayaya
 
 

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org

 		 	   		  
Mime
View raw message