axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sagara Gunathunga <sagara.gunathu...@gmail.com>
Subject Re: Problems parsing XML
Date Tue, 31 Jan 2012 06:38:26 GMT
On Tue, Jan 31, 2012 at 12:18 AM, Lucio Crusca <lucio@sulweb.org> wrote:

> In data lunedì 30 gennaio 2012 18:05:52, Deepal Jayasinghe ha scritto:
> > How did you generate the code ? did you use the ?wsdl and generate the
> > stubs or did you do something else.
>
> I used the ?wsdl and generated the stubs with the following commands:
>
> $AXIS2_HOME/bin/wsdl2java.sh -uri https://xxx.yyy.zzz/wss-demo/SoapServer/-p
> zzz.yyy.xxx.webservices.client.xmlbeans -s -o src-xmlbeans -d xmlbeans
>
> $AXIS2_HOME/bin/wsdl2java.sh -uri https://xxx.yyy.zzz/wss-demo/SoapServer/-p
> zzz.yyy.xxx.webservices.client.adb -s -o src-adb -Eiu -d adb
>
> using axis2 1.7-SNAPSHOT for -Eiu option (but the same happens with 1.6
> without the -Eiu option).
>

I think problem is not with above -Eiu option instead with your WSDL, above
WSDL use SOAP encoding that Axis2 does not support.  In some cases it's
possible to use XMLBean data binding to deal with SOAP encoding ( refer
[1]) but I'm not sure whether it will help out in this case.

[1] - http://ssagara.blogspot.com/2011/10/soap-encoding-and-axis2.html

Thanks !


>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-user-help@axis.apache.org
>
>


-- 
Sagara Gunathunga

Blog      - http://ssagara.blogspot.com
Web      - http://people.apache.org/~sagara/
LinkedIn - http://www.linkedin.com/in/ssagara

Mime
View raw message