axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From phi...@free.fr
Subject java.lang.ArrayIndexOutOfBoundsException: -1
Date Mon, 05 Dec 2011 09:20:17 GMT
Hello,

I have just installed the 1.6.1 axis2.war file in the webapps directory of a tomcat6 server
on Linux.

When I click the Services hyperlink on the Axis2 Home Page, the following message is displayed
in my browser:

Internal server error


and the localhost log file contains the following message:

----------------------------------------

Dec 5, 2011 10:11:47 AM org.apache.catalina.core.StandardContext loadOnStartup
SEVERE: Servlet /axis2 threw load() exception
java.lang.ArrayIndexOutOfBoundsException: -1
        at java.util.ArrayList.get(Unknown Source)
        at com.ctc.wstx.util.TextBuffer.clearSegments(TextBuffer.java:311)
        at com.ctc.wstx.util.TextBuffer.resetWithShared(TextBuffer.java:255)
        at com.ctc.wstx.sr.BasicStreamReader.readTextPrimary(BasicStreamReader.java:4658)
        at com.ctc.wstx.sr.BasicStreamReader.nextFromTree(BasicStreamReader.java:3010)
        at com.ctc.wstx.sr.BasicStreamReader.next(BasicStreamReader.java:1062)
        at org.apache.axiom.util.stax.wrapper.XMLStreamReaderWrapper.next(XMLStreamReaderWrapper.java:225)
        at org.apache.axiom.om.impl.builder.StAXOMBuilder.parserNext(StAXOMBuilder.java:682)
        at org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:215)
        at org.apache.axiom.om.impl.llom.OMSerializableImpl.build(OMSerializableImpl.java:78)
        at org.apache.axiom.om.impl.llom.OMElementImpl.build(OMElementImpl.java:721)
        at org.apache.axis2.util.XMLUtils.toOM(XMLUtils.java:595)
        at org.apache.axis2.util.XMLUtils.toOM(XMLUtils.java:575)
        at org.apache.axis2.deployment.DescriptionBuilder.buildOM(DescriptionBuilder.java:97)
        at org.apache.axis2.deployment.AxisConfigBuilder.populateConfig(AxisConfigBuilder.java:89)
        at org.apache.axis2.deployment.DeploymentEngine.populateAxisConfiguration(DeploymentEngine.java:857)
        at org.apache.axis2.deployment.WarBasedAxisConfigurator.<init>(WarBasedAxisConfigurator.java:156)
        at org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:584)
        at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:454)
        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1161)
        at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:981)
        at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4045)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4351)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
        at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:825)
        at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:714)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:490)
        at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1206)

-------------------------------------------------

Has anyone on this list ever encountered this problem before?

Many thanks.

Philippe

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message