axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sagara Gunathunga <sagara.gunathu...@gmail.com>
Subject Re: Using given WSDLs for service in Axis2
Date Wed, 26 Oct 2011 15:36:30 GMT
Can you try for 2nd option listed here [1] , that mean use .jar
instead of .aar and let us know you results ?

[1] - http://axis.apache.org/axis2/java/core/docs/jaxws-guide.html#DeployService

Thanks !

On Wed, Oct 26, 2011 at 3:53 PM, simonemaletta@alice.it
<simonemaletta@alice.it> wrote:
>   Hi all,
>    I have a great problem deploying a JAX-WS WS on Axis2.
> I'm working on WS refactor.
> I generated Java classes using wsimport tool starting from a given WSDL.
> I obtained PortType Interface that I realize using my own class.
> Now I'm trying to deploy the system on Axis2 using the AAR system, I build
> the project using Maven plugin.
> Here is my services.xml deploy file:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <serviceGroup>
>     <service name="Finish">
>
>         <transports>
>              <transport>http</transport>
>         </transports>
>
>         <messageReceivers>
>             <messageReceiver mep="http://www.w3.org/2004/08/wsdl/in-out"
> class="org.apache.axis2.rpc.receivers.RPCMessageReceiver"></messageReceiver>
>         </messageReceivers>
>
>         <parameter name="ServiceClass">it.init.Finish</parameter>
>
>     </service>
>     <service name="Check">
>
>         <transports>
>              <transport>http</transport>
>         </transports>
>
>         <messageReceivers>
>             <messageReceiver mep="http://www.w3.org/2004/08/wsdl/in-out"
> class="org.apache.axis2.rpc.receivers.RPCMessageReceiver"></messageReceiver>
>         </messageReceivers>
>
>         <parameter name="ServiceClass">it.init.Check</parameter>
>     </service>
>     <service name="Start">
>
>         <transports>
>              <transport>http</transport>
>         </transports>
>
>         <messageReceivers>
>             <messageReceiver mep="http://www.w3.org/2004/08/wsdl/in-out"
> class="org.apache.axis2.rpc.receivers.RPCMessageReceiver"></messageReceiver>
>         </messageReceivers>
>
>         <parameter name="ServiceClass">it.init.Start</parameter>
>     </service>
> </serviceGroup>
>
> I annotated my classes specifying endpointInterface, portName,
> serviceName,wsdlLocation, using WSDLs indications as shown in the following
> example:
>
> @WebService(
>         endpointInterface="com.CheckServicePortType",
>         portName="CheckServiceHttpPort",
>         serviceName="CheckService",
>         wsdlLocation="Check.wsdl")
>
>
> While I deploy my artifact the system do not use given WSDLs but it
> generates them ex-novo.
>
> I put Axis2 in debug level mode to show if something strange occurs during
> the installation. I found:
>
> [DEBUG] AxisOperation::getSoapAction urn:Check
> Could not identify the Annotation....
>
>
> Someone can help me understanding what's happening??
> Thank you very much,
> Simone
>
>



-- 
Sagara Gunathunga

Blog      - http://ssagara.blogspot.com
Web      - http://people.apache.org/~sagara/
LinkedIn - http://www.linkedin.com/in/ssagara

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message