axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stadelmann Josef" <josef.stadelm...@axa-winterthur.ch>
Subject AW: [Rampart-1.6.0] Build fails with JDK 15.0 but succeeds with JDK 1.6.0
Date Thu, 20 Oct 2011 12:32:19 GMT
Andreas

When I build the Rampart project using JDK 1.5.0_18 on Windows Vista
Starting from the root pom.xml fails with the Rampart - Integration Module in the lengthy
test . . .


When I just build the Rampart - Integration Module all works fine including the lengthy tests,
all are running all well.


When I use JDK 1.6.0_22 
Starting from the root pom.xml works perfect including the lengthy test.

This on Windows Vista
But 
I see the same symptoms attempting to build axis2 (not Rampart) on OpenVMS

When the reactor triggers the module build module/codegen fails in the surefire test
When I do the same using mvn install --projects module/codegen all works fine even on OpenVMS
(not using GNV/Bash) but with our own ant-1.7.1-sst in the local cache.


Yesterday, I have built axis2-1.6.0
With maven-2.2.1
On top of Java 1.6.0
On top of OpenVMS

Mvn -Dmaven.test.skip=true install

Any clue
Regards
Sepp





 

-----Ursprüngliche Nachricht-----
Von: Andreas Veithen [mailto:andreas.veithen@gmail.com] 
Gesendet: Montag, 17. Oktober 2011 17:49
An: java-user@axis.apache.org
Betreff: Re: [Rampart-1.6.0] Build fails with JDK 15.0 but succeeds with JDK 1.6.0

Josef,

Rampart normally builds fine with Java 1.5. There is however a known
issue that occurs when the JRE provides a Xerces version that uses the
original package name (org.apache.xerces). I've seen this on IBM JDKs,
while with Sun/Oracle JDKs, they normally use a Xerces version with a
modified package name (com.sun.*). Is it possible that you have added
Xerces to the endorsed libraries of the JRE?

Andreas

On Mon, Oct 17, 2011 at 17:03, Stadelmann Josef
<josef.stadelmann@axa-winterthur.ch> wrote:
> I have a demand to build Rampart using JDK 1.5.0_18
>
> /asf/axis/axis2/java/core/tags/v1.6.0           using JDK1.5.0_18 success
>
> /asf/axis/axis2/java/rampart/tags/v1.6.0        using JDK1.5.0_18 failed
>
> /asf/axis/axis2/java/rampart/tags/v1.6.0        using JDK1.6.0_22 success
>
> This on Windows Vits SP2
>
> One could now arg that it isnot necessary to build Rampart under JAVA
> 1.5.0_18
>
> But our JVM on OpenVMS to which we move the built Rampart tereafter does not
> have
>
> A JPDA Debugger Port for its JDK 1.6.0_22 JVM, hence we are unable to debugg
> on
>
> OpenVMS as we can't have sources and jars built with different JAVA
> Compilers
>
> And expect the debugger to work correctly under NetBeans
>
> In this case the only working way is tio use JDK 1.5.0_18 and maven 2.2.1 to
> build
>
> Rampart. However that fails while building with JDK 1.6.0_22 builds
> successfully.
>
> Question:
>
> Is it possible to build Rampart-1.6.0 like Axis2-1.6.0 using a JAVAC 1.5.0
> compiler?
>
> In this case the following failer occures when building Rampart-1.6.0 taged
> version.
>
> The build log is attached here.
>
> <<Rampart_build_with_JDK_1.5.0_18.log>>
>
> What are your recommenadtions
>
> Josef
>
> using
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-user-help@axis.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message