axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Error with wsdl2java, axis 1.6.1
Date Sun, 25 Sep 2011 12:12:32 GMT
It will be documented in the release notes for Rampart 1.6.1 and we
will also mention that in the announcement for these releases (which
will be sent when all releases are done).

The rule is that you should always use the latest versions from
corresponding branches, i.e. Axis2 1.5.6 + Rampart 1.5.2 (release in
progress) + Sandesha2 1.4 or Axis2 1.6.1 + Rampart 1.6.1 (release in
progress) + Sandesha2 1.6.1 (will be released soon after Rampart).

Andreas

On Thu, Sep 22, 2011 at 13:29, Leon Koch <Leon.Koch@global-health.com> wrote:
> Thanks. I'll roll back to 1.6.0 and keep an eye out for the rampart release.
>
> Not to be smart, but is this incompatibility documented anywhere? I know from when rampart
was using x.y version numbers, they seemed to work across multiple versions of axis (1.5.1,
1.5.2, etc), so I assumed that was still the case.
>
> Should we now always assume that modules with different versions from axis will be incompatible?
> ________________________________________
> From: Andreas Veithen [andreas.veithen@gmail.com]
> Sent: Thursday, 22 September 2011 7:08 PM
> To: java-user@axis.apache.org
> Subject: Re: Error with wsdl2java, axis 1.6.1
>
> You will have to wait for Rampart 1.6.1 which will be released soon.
>
> Andreas
>
> On Thu, Sep 22, 2011 at 12:21, Leon Koch <Leon.Koch@global-health.com> wrote:
>> Hi,
>>
>> I am attempting to re-build some server side code + stubs using axis 1.6.1 and rampart
1.6.0. I am getting the following error:
>>
>> # wsdl2java.bat -uri Test.wsdl -o generated -or -p test -ss -sd -ssi -uw --noBuildXML
>>
>>  Using AXIS2_HOME: C:\bin\axis2-1.6.1
>>  Using JAVA_HOME:  C:\Program Files\Java\jdk1.6.0_27
>> Retrieving document at 'Test.wsdl'.
>> Exception in thread "main" org.apache.axis2.wsdl.codegen.CodeGenerationException:
Error parsing WSDL
>>        at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.<init>(CodeGenerationEngine.java:175)
>>        at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:35)
>>        at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:24)
>> Caused by: org.apache.axis2.AxisFault: java.lang.Class cannot be cast to java.lang.reflect.ParameterizedType
>>        at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
>>        at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.populateService(WSDL11ToAxisServiceBuilder.java:411)
>>        at org.apache.axis2.description.WSDL11ToAllAxisServicesBuilder.populateAllServices(WSDL11ToAllAxisServicesBuilder.java:107)
>>        at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.<init>(CodeGenerationEngine.java:169)
>>        ... 2 more
>> Caused by: java.lang.ClassCastException: java.lang.Class cannot be cast to java.lang.reflect.ParameterizedType
>>        at org.apache.neethi.AssertionBuilderFactoryImpl.findAssertionBuilderTarget(AssertionBuilderFactoryImpl.java:136)
>>        at org.apache.neethi.AssertionBuilderFactoryImpl.invokeBuilder(AssertionBuilderFactoryImpl.java:128)
>>        at org.apache.neethi.AssertionBuilderFactoryImpl.build(AssertionBuilderFactoryImpl.java:110)
>>        at org.apache.neethi.PolicyBuilder.processOperationElement(PolicyBuilder.java:225)
>>        at org.apache.neethi.PolicyBuilder.getAllOperator(PolicyBuilder.java:185)
>>        at org.apache.neethi.PolicyBuilder.processOperationElement(PolicyBuilder.java:218)
>>        at org.apache.neethi.PolicyBuilder.getExactlyOneOperator(PolicyBuilder.java:181)
>>        at org.apache.neethi.PolicyBuilder.processOperationElement(PolicyBuilder.java:216)
>>        at org.apache.neethi.PolicyBuilder.getPolicyOperator(PolicyBuilder.java:175)
>>        at org.apache.neethi.PolicyBuilder.getPolicy(PolicyBuilder.java:125)
>>        at org.apache.neethi.PolicyEngine.getPolicy(PolicyEngine.java:113)
>>        at org.apache.axis2.util.PolicyUtil.getPolicyComponent(PolicyUtil.java:171)
>>        at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.processPoliciesInDefintion(WSDL11ToAxisServiceBuilder.java:3119)
>>        at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.processPoliciesInDefintion(WSDL11ToAxisServiceBuilder.java:3097)
>>        at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.populateService(WSDL11ToAxisServiceBuilder.java:374)
>>        ... 4 more
>>
>> When using axis 1.6.0 and rampart 1.6.0, the server side code and stubs are generated
without error.
>>
>> The sample wsdl is attached.
>>
>> From the stack trace, it looks like the upgrade to neethi v3.0.1 that happened in
axis 1.6.1 is causing issues with our policy, but I'm not sure how to resolve it.
>>
>> I suspect I'm not the only one hitting this, as googling found this: http://stackoverflow.com/questions/7397591/axis2-1-6-1-vs-rampart-1-6-0-compatibility
>>
>> Any ideas?
>>
>> Thanks
>> Leon
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
>> For additional commands, e-mail: java-user-help@axis.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-user-help@axis.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
> For additional commands, e-mail: java-user-help@axis.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message