axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack Sprat <rexclaim...@yahoo.com>
Subject Re: [Axis2] How to debug NPE
Date Tue, 13 Sep 2011 02:33:07 GMT
That is the problem.  I have no idea where the error is occurring and don't know where the
error and/or stack trace is being logged.  There is nothing in system.err or system.out or
any of the Websphere logs that I can see.  There is only the NPE in the SOAP reply.



________________________________
From: Deepal Jayasinghe <deepal@opensource.lk>
To: java-user@axis.apache.org
Sent: Monday, September 12, 2011 6:09 PM
Subject: Re: [Axis2] How to debug NPE


Could you please send us the complete stack trace ? 

Deepal


The Websphere server is running in debug mode.  I have a breakpoint already set in the echo
operation of the service class but the NPE is happening before that.  How can I debug prior
to reaching the code in this service?  How can I tell where the NPE is occurring?
>
>
>
>Thanks.
>
>
>
>
>________________________________
>From: Deepal jayasinghe <deepalk@gmail.com>
>To: java-user@axis.apache.org
>Sent: Monday, September 12, 2011 4:46 PM
>Subject: Re: [Axis2] How to debug NPE
>
>
>You need to do the remote debugging, or else you can setup the server code in your IDE
and start a simple HTTP server and test your code.
>
>Look at "Listing 2. Deploying a POJO in Axis2" here - http://www.ibm.com/developerworks/library/ws-axis2soap/index.html
>
>Deepal
>
>I've got a new Axis2 1.5.2 web service using XML Beans binding.  The code was generated
with WSDL2Java.  I can access the WSDL using the ?wsdl link.
>>There is a simple echo operation to test connectivity.  This yields a Null Pointer
exception in the SOAP reply.
>>
>>
>>My question is how do I debug this?  I have a breakpoint in my service class but
it is not getting that far.
>>
>>
>>Thanks.
>>
>>
>
>
>

-- 
Blog - http://blogs.deepal.org/
Mime
View raw message