axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From darkling235 <darkling...@aol.com>
Subject XMLSpy says WSDL is invalid but axis2 works with it
Date Tue, 16 Aug 2011 11:32:47 GMT

We're having problems using our WSDL in XMLSpy. It works fine in our system
but apparently there's something nonstandard about it that XMLSpy doesn't
like. We keep getting this error:

File http://localhost:8080/ScaleBaseAPI/services/ServersService?wsdl is not
valid.
	attribute 'part' in extensibility element '<mime:content>' refers to part
'removeShardKeyCLI' which could not be found in message
'removeShardKeyCLIRequest'
		Error location: wsdl:definitions / wsdl:binding / wsdl:operation /
wsdl:input / mime:content / @part


The errors have been changing as I modify our java class that the wsdl
generates from but they always say that something is missing from the
request object. Do I need to run XML Spy with special parameters to get this
to work? Or do I need to run AXIS2 with special parameters to get this to
work?  http://old.nabble.com/file/p32271061/ServersService.wsdl.xml
ServersService.wsdl.xml 
-- 
View this message in context: http://old.nabble.com/XMLSpy-says-WSDL-is-invalid-but-axis2-works-with-it-tp32271061p32271061.html
Sent from the Axis - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message