axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Le Anh Tuan <zen...@gmail.com>
Subject AClassNotFoundException on MessageReceiverInOut
Date Fri, 15 Jul 2011 04:09:46 GMT
I got error notice when I tried to run axis2:

[INFO] script module activated
org.apache.axis2.deployment.DeploymentException: A ClassNotFoundException
error
occurred in loading the message receiver
com.ttdev.ss.SimpleServiceMessageReceiverInOut


I checked my services.xml that generated by Eclipse Code Generator Plugin:

<?xml version="1.0" encoding="UTF-8"?>
<!-- This file was auto-generated from WSDL -->
<!-- by the Apache Axis2 version: 1.6.0  Built on : May 17, 2011 (04:19:43
IST) -->
<serviceGroup>
    <service name="SimpleService">
        <messageReceivers>
            <messageReceiver mep="http://www.w3.org/ns/wsdl/in-out"
class="com.ttdev.ss.SimpleServiceMessageReceiverInOut"/>
        </messageReceivers>
        <parameter
name="ServiceClass">com.ttdev.ss.SimpleServiceSkeleton</parameter>
        <parameter name="useOriginalwsdl">true</parameter>
        <parameter name="modifyUserWSDLPortAddress">true</parameter>
        <operation name="concat" mep="http://www.w3.org/ns/wsdl/in-out"
namespace="http://ttdev.com/ss">
            <actionMapping>http://ttdev.com/ss/NewOperation</actionMapping>
            <outputActionMapping>
http://ttdev.com/ss/SimpleService/concatResponse</outputActionMapping>
        </operation>
    </service>
</serviceGroup>


Yes, they do have messageReceiver class parameter and I don't understand why
this error happened.
My problem is similar to old one here:
http://www.coderanch.com/t/535069/Web-Services/java/Web-Services-AXIS .
Unfortunately, that thread hasn't got solution yet.

Mime
View raw message