axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adil Allawi <a...@diwan.com>
Subject Async web service issue in Axis2 1.5.4
Date Tue, 05 Apr 2011 08:54:27 GMT
I am trying to get Axis2 to invoke my web service asynchronously and 
failing. I am beginning to thing this is due to a bug in Axis2. As I 
understand it, to get axis2 to launch a web service asynchronously, you 
need two conditions:

1/ The web service services.xml file contains the following parameter :

<parameter name="messageReceiver.invokeOnSeparateThread">true</parameter>

and 2/ the soap request contains a replyTo address. Which is tent in my 
test as follows:

<?xml version='1.0' encoding='utf-8'?>
<soapenv:Envelope xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope">
<soapenv:Header xmlns:wsa="http://www.w3.org/2005/08/addressing">
<wsa:To>http://localhost:8080/axis2/services/Translate.TranslateSOAP12port_http/</wsa:To>
<wsa:ReplyTo>
<wsa:Address>http://10.0.1.9:6060/axis2/services/Translate1301967596334_1/</wsa:Address>
</wsa:ReplyTo>
<wsa:MessageID>urn:uuid:B967748EA6454E078A1301967596581</wsa:MessageID>
<wsa:Action>urn:breakSentences</wsa:Action>
</soapenv:Header>
<soapenv:Body>
<ns4:breakSentences xmlns:ns4="http://translation/diwan/com/xsd" />
</soapenv:Body>
</soapenv:Envelope>

Axis2 checks for these in 
org.apache.axis2.receivers.AbstractMessageReceiver.receive(). However 
the mesageContext passed gets null for the call messageCtx.getReplyTo(). 
But there is a ReplyTo in the soap body.

Is this a bug or am I missing something.

thanks

Adil


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message