axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjay Gupta <>
Subject RE: Consuming Axis1 Service from Axis2
Date Wed, 02 Feb 2011 06:22:14 GMT
Hi Dmitry,

Thanks for your reply. I have had some issues in the past because of jar conflicts when I
tried to use a 3rd party vendor’s web services almost a year back. I am going to try again.


From: Dmitry Ruban []
Sent: Monday, January 31, 2011 7:05 PM
Subject: Re: Consuming Axis1 Service from Axis2

Hello Sanjay,

We have been using both Axis2 and Axis1 in our application without any issues. Why do you
think Axis1 and Axis2 can't work side by side? Cheers

On 31/01/11 16:23, Sanjay Gupta wrote:

Yes it is using RPC/Encoding which is my problem. We asked the 3rd party app vendor and they
are aware that they are using obsolete encoding but they don’t have any plan in the near
term to make any changes. So I am kind of stuck. I was wondering if anybody figured out a
workaround. My preference is to make the call inside my web app which is not possible since
I am already using axis2.



From: am am []
Sent: Saturday, January 29, 2011 1:23 PM
Subject: Re: Consuming Axis1 Service from Axis2


From the error, it seems that the web service is using RPC/Encoding.
This is an obsolete encoding (non compliant with WS-I Profile) and no java frameworks supports
it any more.
You must use axis1 (only this version supports) to consume the web service.
Also you should ask the providers why are they exposing the service as a legacy service.

From: Sanjay Gupta <><>
To: ""<> <><>
Sent: Fri, January 28, 2011 8:24:42 PM
Subject: Consuming Axis1 Service from Axis2

I need to consume a third party service that’s written in axis1. I tried to use axis2 wsdl2java
to generate stub and got error show below. I really can’t use axis1 since I already use
axis2 in my web app. I was wondering if anybody encountered this scenario and was able to
successfully consume axis1 web services in an environment where axis2 was present. I would
greatly appreciate any help.

Caused by: org.apache.axis2.schema.SchemaCompilationException: can not find type {}Array<>
from the parent schema



View raw message