axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shannnon Heimburg" <Shann...@mindgold.org>
Subject RE: [Axis2] Unable to Install Eclipse Plugins
Date Fri, 21 Jan 2011 19:37:07 GMT
Thanks for your help, Harshana.

 

It turns out that I wasn’t using the right version of Eclipse.  I downloaded Eclipse for
Java EE developers and the Axis wizards worked fine. 

 

 

 

From: Harshana Eranga Martin [mailto:harshana05@gmail.com] 
Sent: Wednesday, January 19, 2011 1:35 AM
To: java-user@axis.apache.org
Subject: Re: [Axis2] Unable to Install Eclipse Plugins

 

Hi Shannon,

On 19 January 2011 11:28, Harshana Eranga Martin <harshana05@gmail.com> wrote:

Hi Shannon

 

On 19 January 2011 08:37, Shannnon Heimburg <ShannonH@mindgold.org> wrote:

I am trying to install the service archive generator wizard plug-in for Eclipse.   I have
Eclipse Helios release 3.6.1, so it has the dropins directory.  I just downloaded the zip
file for the service archive generator wizard.  I think it was 1.5.4.  I also downloaded the
zip file for the code generator wizard plug-in.  I placed the two jar files in the dropins
directory under the Eclipse directory.  I opened Eclipse, looked under File-New-Other but
the Axis folder isn’t there.  I tried placing the jars in the plugins directory instead,
but that didn’t work either.   So I looked online and found the following issue https://issues.apache.org/jira/browse/AXIS2-4896
  I downloaded the jar files at the two links https://hudson.apache.org/hudson/job/axis2-1.5/lastBuild/org.apache.axis2$axis2.eclipse.codegen.plugin/
and https://hudson.apache.org/hudson/job/axis2-1.5/lastBuild/org.apache.axis2$axis2.eclipse.service.plugin/
 (which were 1.5.5) and placed them in the dropins directory instead of the 1.5.4 ones.  That
didn’t work either.  What am I doing wrong?

 

Thanks,

Shannon

 

 

AKAIU, you have not done anything wrong here. Only thing I can think of is, you have not placed
1.5.5 jars under the plugins folder. 

 

AXIS2-4896[0] was fixed in the 1.5 and seems you have downloaded it and already tried. Please
try the following approaches and let us know, how it goes.

 

1. Download the 1.5.5 zip archives from the links mentioned in the Axis2-4896 and extract
them and placed under plugins folder. (Instead of dropins, placed them under the plugins folder).
Try starting Eclipse with "-clean" option.

 

2. If first approach also does not work, try starting the Eclipse with -"console" option and
try install the plugins manually to Eclipse via OSGi console. Then you will be able to see
errors/exceptions if there are any.

 

Please let us know what is the Eclipse distribution you are using (whether it is Eclipse J2EE
version or any other)

 

I tried installing the plugins in a new Helios J2EE version and in a new Helios Modeling version
and only the J2EE Helios is able to resolve the Axis2 plugins. Modeling version did not identify
the Axis2 plugins. Therefore i think it has to do something with the plugin dependencies and
therefore Modeling version and other versions of Eclipse might not able to install the Axis2
plugins. So it might be the issue in your case too. 

 

Thanks and Regards,

Harshana

 

 

[0].  https://issues.apache.org/jira/browse/AXIS2-4896




Thanks and Regards,
Harshana Martin
--
Harshana Eranga Martin
Software Engineer,

WSO2 Inc.

Web: http://wso2.com 

           http://wso2.org

 

ECF Committer: http://www.eclipse.org/ecf/
Blog: http://harshana05.blogspot.com
Profile: https://www.google.com/profiles/harshana05

 




-- 
Thanks and Regards,
Harshana Martin
--
Harshana Eranga Martin
Software Engineer,

WSO2 Inc.

Web: http://wso2.com 

           http://wso2.org

 

ECF Committer: http://www.eclipse.org/ecf/
Blog: http://harshana05.blogspot.com
Profile: https://www.google.com/profiles/harshana05

 


Mime
View raw message