axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: help needed building axis2 using NetBeans 6.8 and maven 2.2.1
Date Tue, 27 Jul 2010 22:07:02 GMT
Looks like the Axis2 trunk build now works with Maven 3.0 (beta1).

Andreas

On Tue, Feb 16, 2010 at 11:31, Stadelmann Josef
<josef.stadelmann@axa-winterthur.ch> wrote:
> Hi Andreas,
>
> thank you for your excellent analysis. It is exactly what I are faced with.
> I just learned that what is built with an earlier version of maven is not
> what actually works on a given project. I was just failing into this trap
> because I've built all versions of maven from sources and used by default
> the latest greates maven 3.0
>
> Now I have the luxury to select the proper maven version used for axis2 builds
> and it works error free with maven 2.2.1
>
> But I am not that maven guru yet like you able to fix all problems seen with maven 3.0
> So, thanks for the help
>
> Josef.Stadelmann
> @axa-winterthur.ch
>
>
>
>
> -----Ursprüngliche Nachricht-----
> Von: Andreas Veithen [mailto:andreas.veithen@gmail.com]
> Gesendet: Mittwoch, 3. Februar 2010 11:28
> An: axis-user@ws.apache.org
> Cc: axis-dev@ws.apache.org
> Betreff: Re: help needed building axis2 using NetBeans 6.8 and maven 2.2.1
>
> On Tue, Feb 2, 2010 at 10:06, Stadelmann Josef
> <josef.stadelmann@axa-winterthur.ch> wrote:
>> Andreas,
>>
>> Summary:
>>
>> Builds using MAVEN 2.2.1
>> Source Code used,
>> Cmd window              NetBeans IDE 6.8                      
 Maven
>> Flags
>> downloaded by SVN Tortoise                                    
 Maven
>> 2.2.1           external Maven 2.2.1
>>
>> Ant 1.7.0               external Ant 1.7.0
>>
>> C:\asf\webservices\axis2\tags\java\v1.5.1               fails
>> fails                                   -Dmave.test.skip=true
>> C:\asf\webservices\axis2\tags\java\v1.5.1               success
>> success                         .NA.
>>
>> C:\asf\webservices\axis2\trunk\java                             success
>> success                         -Dmave.test.skip=true
>> C:\asf\webservices\axis2\trunk\java                             success
>> success                         .NA.
>>
>> Builds using MAVEN 3.0-SNAPSHOT                         AXIS2 is not
yet
>> maven 3.0-Snapshot ready!
>>
>> If you have NetBeans IDE 6.8 with the internal or external maven
>> 3.0-snapshot then you are unable to open the axis2 root POM correctly.
>> However one is  still able to build some off the axis2
>> components/artifacts correctly. In short AXIS2 Trunk sources and earlier
>> are not yet ready for MAVEN 3.0-SNAPSHOT!
>>
>> Josef
>
> Maven 3.0 (alpha-6) actually works surprisingly well on the Axis2
> build. There are only two issues:
>
> - A duplicate dependency declaration in the integration module; this
> is now fixed.
>
> - The root POM has an antrun execution that depends on the output of
> several of its sub-modules by directly accessing
> modules/xxx/target/classes, but no provisions are made to make sure
> that these modules are built before the antrun execution. Depending on
> the output of other modules in that way is bad practice, and leads to
> unstable/unpredictable build. With Maven 2.0 the build order is such
> that it works correctly, but this is probably more a coincidence. We
> will probably have to use some maven-assembly-plugin magic to do this
> correctly and to make the build order predictable.
>
> Andreas
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


Mime
View raw message