axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Wang <jessiedanw...@yahoo.com>
Subject Re: [Axis2] Error Loading Message Receiver - Please help
Date Mon, 26 Jul 2010 14:38:05 GMT
Thanks, Robert.

I was having axis2.war and my web app with embedded axis2 web service deployed 
at the same time. After undeploy axis2.war, my web app is working without any 
problem.

Jessie




________________________________
From: robert lazarski <robertlazarski@gmail.com>
To: java-user@axis.apache.org
Sent: Wed, July 21, 2010 5:32:24 PM
Subject: Re: [Axis2] Error Loading Message Receiver - Please help

On Wed, Jul 21, 2010 at 7:20 PM, Dan Wang <jessiedanwang@yahoo.com> wrote:
> Thanks Deepal for your quick response.
>
> Here is the message receiver part of my services.xml file,
>
>         <messageReceivers>
>             <messageReceiver mep="http://www.w3.org/ns/wsdl/in-out"
> class="com.xxx.www.MyServiceMessageReceiverInOut"/>
>         </messageReceivers>
>
> And I DO have it in the compiled class.
>

I'd expect you'd get an error besides NoClassDefFound if it was a jdk error.

I'd look at the happy axis2 page , which shows the jars and their file
paths. However, my best guess is that the name of the class is spelled
wrong somewhere or one of the chars is the wrong case. If you are sure
its correct, try something like this:

com.xxx.www.MyServiceMessageReceiverInOut obj = new
com.xxx.www.MyServiceMessageReceiverInOut();

System.out.println(obj.getClass().getName()
+ " is loaded from " +

obj.getClass().getProtectionDomain().getCodeSource().getLocation());

- R

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org


      
Mime
View raw message