axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BBQ ZenMaster <bbqzenmas...@sbcglobal.net>
Subject Solved: Retry: Invalid SOAP response with Axis2?
Date Wed, 30 Jun 2010 14:14:10 GMT
Just to close the loop on this one...

I should have seen this easily.  Too much staring at SOAP messages had blinded me apparently. 
The xmlns entries were being changed by the server.  Apparently the SOAP framework they used
generates generic namespace entries and they have to manually modify them.  A quick change
on their side fixed the issue.

Thanks.
Mike



________________________________
From: BBQ ZenMaster <bbqzenmaster@sbcglobal.net>
To: java-user@axis.apache.org
Sent: Tue, June 29, 2010 3:01:48 PM
Subject: Retry: Invalid SOAP response with Axis2?


Sorry for the partial message sent before this... hand twitched and sent the email.

I'm trying to use AXIS2 to call a simple web service.  I got the WSDL from a developer working
on a System I server using i/OS.  I used WSDL2Java to generate the stub and wrote a simple
service client.  I used tcpmon to watch the traffic.  When I first tried, the server side
(black box) was returning an 'HTTP/1.1 400 Bad Request'.  Even with that error code, the
response in tcpmon looked OK.  AFter much digging, the only thing I could find was a possible
issue with: 

'Tansfer-Encoding: chunked' 

so I used:
 
HelloServiceStub stub = new HelloServiceStub();
stub._getServiceClient().getOptions().setProperty(org.apache.axis2.transport.http.HTTPConstants.CHUNKED,
Boolean.FALSE); 
 
...to stop chunking (on the request at least).  That got rid of the HTTP error, but AXIS
still thinks there is something wrong with the response.  The error AXIS2 has now says:

 
org.apache.axis2.AxisFault: Only SOAP 1.1 or SOAP 1.2 messages are supported in the system
 at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
 at org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:123)

 
I have attached the request/response in a text file... any ideas what's wrong with the response?
 
Thanks.
 
Mike
---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@axis.apache.org
For additional commands, e-mail: java-user-help@axis.apache.org
Mime
View raw message