axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adnan <adn...@yahoo.com>
Subject Re: Error sending message: Transport out has not been set
Date Thu, 27 May 2010 13:17:08 GMT
Thank you.
http:// was there... 
Spent many days on it... but at the end when I narrowed it down then I found that there was
A space before the http:// 
:(

thx 

----
AL




________________________________
From: Andy Dysart <ADysart@prospricing.com>
To: "java-user@axis.apache.org" <java-user@axis.apache.org>
Sent: Wed, 26 May, 2010 18:19:11
Subject: RE: Error sending message: Transport out has not been set

 
I got exactly this same error when my endpoint URL was not
correctly defined.  It needs to start with http:// or https://, or one of the
other transports that is supported by Axis2.  Hope this helps.
 
-andy
 
From:Adnan
[mailto:adnust@yahoo.com] 
Sent: Wednesday, May 26, 2010 4:39 AM
To: java-user@axis.apache.org
Subject: Error sending message: Transport out has not been set
 
Hello.

I have spent many days sorting out this problem but did not get any solution,
this mail should be in ode list but (it is there) but i sending it here because
the error i am getting is from axis2, either i am missing somthing or there
might be somthing wrong with ode-axis2 interface . I googled this error and
found that this could be because of missing jar in classpath (like
httpclient-4.0.1.jar) but i am sure it is there.

Here is the error i am getting. Using ode1.3.4rc, windows and mac, java6. 

34:27-DEBUG [BpelRuntimeContextImpl] Setting execution state on instance 1851
34:28-DEBUG [SessionOutHandler] Sending stateful TO epr in message header using
session null
34:28-DEBUG [SessionOutHandler] Sending a message containing wsa endpoints in
headers for session passing.
34:28-DEBUG [SessionOutHandler] 
der>http://localhost:8080/Add/AddService  http://www.w3.org/200
5/08/addressing">http://www.w3.org/2005/08/addressing/anonymous
ddr:Address>uuid:hqejbhcnphr5b1pnjghfrg'>http://www.w3.org/2005/08/addressing">uuid:hqejbhcnphr5b1pnjghfrg
penv:Body>
                                                       
<num1 xmlns="">5</num1>
                                                       
<num2 xmlns="">5</num2>
                                               
</addMethod></soapenv:Body></soapenv:Envelope>
34:28-ERROR [ExternalService] Error sending message (mex={PartnerRoleMex#hqejbhcnphr5b1pnjghfrd
[PID {http://SocPrc}SocPrc-1]
calling org.apache.ode.bpel.epr.
URLEndpoint@19347e8.addMethod(...)}): Transport out has not been set
org.apache.axis2.AxisFault: Transport out has not been set
        at
org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:383)
        at
org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:374)
        at
org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:211)
        at
org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
        at
org.apache.ode.axis2.SoapExternalService$1$1.call(SoapExternalService.java:201)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at
java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at
java.lang.Thread.run(Thread.java:619)
34:28-DEBUG [PartnerRoleMessageExchangeImpl] replyWithFailure
mex=hqejbhcnphr5b1pnjghfrd failureType=COMMUNICATION_ERROR description=Error
sending message (me
x={PartnerRoleMex#hqejbhcnphr5b1pnjghfrd [PID {http://SocPrc}SocPrc-1]
calling org.apache.ode.bpel.epr.URLEndpoint@19347e8.addMethod(...)}): Transport
out has
 not been set details=null

I am generating bpel, wsdl, xsd and deploy.xml without any ide. (but verified
the bpel, validated the wsdl, xsd, deploy.xml using eclipse). 

Just want to know where could be the problem.

 thx
----
AL


      
Mime
View raw message