axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Håkon Sagehaug <hakon.sageh...@uni.no>
Subject Re: Does Axiom support element ref attribute
Date Tue, 05 Jan 2010 11:42:48 GMT
Hi

I'll see if I can do it soon.

Håkon

2010/1/5 Andreas Veithen <andreas.veithen@gmail.com>

> Håkon,
>
> Can you provide the full stack trace of the error?
>
> Andreas
>
> 2010/1/5 Håkon Sagehaug <hakon.sagehaug@uni.no>:
> > Hi
> >
> > I think it was after, looks like the date for the patch was 30 of
> October,
> > and I tried it in December.
> >
> > Håkon
> >
> >
> > 2010/1/3 Andreas Veithen <andreas.veithen@gmail.com>
> >>
> >> Håkon,
> >>
> >> Was that with a snapshot before or after the change done by Amila [1].
> >>
> >> Andreas
> >>
> >> [1] http://svn.apache.org/viewvc?view=revision&revision=831203
> >>
> >> 2009/12/22 Håkon Sagehaug <hakon.sagehaug@uni.no>:
> >> > Hi
> >> >
> >> > As far as I remember, the same as for axis 1.5.1 applies for
> >> > axis2-snapshot
> >> >
> >> > cheers, håkon
> >> >
> >> > 2009/12/21 Andreas Veithen <andreas.veithen@gmail.com>
> >> >>
> >> >> What about Axis2 snapshot with security enabled?
> >> >>
> >> >> Andreas
> >> >>
> >> >> 2009/12/14 Håkon Sagehaug <hakon.sagehaug@uni.no>:
> >> >> > Hi Andreas,
> >> >> >
> >> >> > Set  up that works,
> >> >> >
> >> >> > schema looks like this(with the ref attribute)
> >> >> >
> >> >> > <xsd:element ref="eyb:MessageBoard"    minOccurs="0" />
> >> >> >
> >> >> > Using axis2 1.5.1, using axiom 1.2.8.jar  and security disabled
> >> >> >
> >> >> > Not working
> >> >> >
> >> >> > Using axis2 1.5.1, using axiom 1.2.8.jar  and security enabled
> >> >> >
> >> >> >
> >> >> > hope this helps
> >> >> >
> >> >> > cheers, Håkon
> >> >> >
> >> >> >
> >> >> > 2009/12/12 Andreas Veithen <andreas.veithen@gmail.com>
> >> >> >>
> >> >> >> Håkon,
> >> >> >>
> >> >> >> I believe it is a problem in ADB (or was, because Amila
> implemented
> >> >> >> a
> >> >> >> workaround). Can you please let us know precisely which
> combinations
> >> >> >> (Axis2 version; security enabled/disabled) work and which
ones
> >> >> >> don't?
> >> >> >>
> >> >> >> Andreas
> >> >> >>
> >> >> >> 2009/12/11 Håkon Sagehaug <hakon.sagehaug@uni.no>:
> >> >> >> > Hi Andreas,
> >> >> >> >
> >> >> >> > Thanks for the pointer, it worked when I used the axis2
> snapshot,
> >> >> >> > but
> >> >> >> > I
> >> >> >> > my
> >> >> >> > service I also have security enabled and then I got the
same
> >> >> >> > message,
> >> >> >> > but I
> >> >> >> > guess from reading the thread that was expected.
> >> >> >> >
> >> >> >> > Is this an issue for rampart, axis2 or axiom?
> >> >> >> >
> >> >> >> > cheers, Hå
> >> >> >> >
> >> >> >> >
> >> >> >> >
> >> >> >> > 2009/12/10 Andreas Veithen <andreas.veithen@gmail.com>
> >> >> >> >>
> >> >> >> >> This issue has been discussed here:
> >> >> >> >> http://markmail.org/thread/w5yziktixvjn7ubl
> >> >> >> >>
> >> >> >> >> Andreas
> >> >> >> >>
> >> >> >> >> 2009/12/10 Håkon Sagehaug <hakon.sagehaug@uni.no>:
> >> >> >> >> > Hi all,
> >> >> >> >> >
> >> >> >> >> > I had a element in a schema that referred another
element
> like
> >> >> >> >> > this
> >> >> >> >> >
> >> >> >> >> >     <xsd:element ref="eyb:MessageBoard" minOccurs="0"
/>
> >> >> >> >> >
> >> >> >> >> > So when I when I called my service and this
element was
> >> >> >> >> > returned
> >> >> >> >> > the
> >> >> >> >> > serialization through an exception like this
> >> >> >> >> >
> >> >> >> >> > [ERROR] Could not get parser from data source
for element
> >> >> >> >> > {http://esysbio.org/service/UserManagement}GetUserResponse<http://esysbio.org/service/UserManagement%7DGetUserResponse>
> >> >> >> >> > javax.xml.stream.XMLStreamException: the prefix
==>  Already
> >> >> >> >> > exists
> >> >> >> >> > for
> >> >> >> >> > namespace ==> http://esysbio.org/common/schema
> >> >> >> >> >
> >> >> >> >> > I then changed my element to take the type instead
of
> referring
> >> >> >> >> > to
> >> >> >> >> > the
> >> >> >> >> > element
> >> >> >> >> >
> >> >> >> >> >     <xsd:element name="MessageBoard"
> >> >> >> >> > type="eyb:MessageBoardType"
> >> >> >> >> >                 minOccurs="0" />
> >> >> >> >> >
> >> >> >> >> >
> >> >> >> >> > Then the service returned the correct response.
So i was
> >> >> >> >> > wondering
> >> >> >> >> > if
> >> >> >> >> > this
> >> >> >> >> > is a limitation of axiom?
> >> >> >> >> >
> >> >> >> >> > I use axis2 .5 and axiom 1.2.8, also tried with
> >> >> >> >> > axiom-1.2.9-SNAPSHOT
> >> >> >> >> > but
> >> >> >> >> > same issue.
> >> >> >> >> >
> >> >> >> >> > Any hint
> >> >> >> >> >
> >> >> >> >> > cheers, Håkon
> >> >> >> >> >
> >> >> >> >> > --
> >> >> >> >> >
> >> >> >> >
> >> >> >> >
> >> >> >
> >> >> >
> >> >> >
> >> >> > --
> >> >> > Håkon Sagehaug, Scientific Programmer
> >> >> > Parallab, Bergen Center for Computational Science(BCCS)
> >> >> > Uni BCCS/Uni Research
> >> >> > Hakon.Sagehaug@uni.no, phone +47 55584125
> >> >> >
> >> >
> >> >
> >> >
> >> > --
> >> > Håkon Sagehaug, Scientific Programmer
> >> > Parallab, Bergen Center for Computational Science(BCCS)
> >> > Uni BCCS/Uni Research
> >> > Hakon.Sagehaug@uni.no, phone +47 55584125
> >> >
> >
> >
> >
> > --
> > Håkon Sagehaug, Scientific Programmer
> > Parallab, Bergen Center for Computational Science(BCCS)
> > Uni BCCS/Uni Research
> > Hakon.Sagehaug@uni.no, phone +47 55584125
> >
>



-- 
Håkon Sagehaug, Scientific Programmer
Parallab, Bergen Center for Computational Science(BCCS)
Uni BCCS/Uni Research
Hakon.Sagehaug@uni.no, phone +47 55584125

Mime
View raw message