axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Building axis2-1.5.1 with maven2 fails, due to wrong repos?
Date Wed, 13 Jan 2010 13:12:30 GMT
Now I remember. The problem occurs because java.net messed up their
repository. On the trunk we fixed that [1]. You will have to do the
same change to the 1.5.1 sources (or set up something in your Maven
settings.xml to override the settings in Axis2).

Andreas

[1] http://svn.apache.org/viewvc/webservices/axis2/trunk/java/modules/parent/pom.xml?r1=835405&r2=835404&pathrev=835405

On Wed, Jan 13, 2010 at 14:01, Patrick Kirsch <p-kirsch@gmx.de> wrote:
> Andreas Veithen schrieb:
>> Maybe it helps to empty the
>> /home/kadmin/.m2/repository/org/apache/ws/commons/axiom folder to
>> force Maven to download the corrupted artifacts again.
> Well it turns out that:
> /home/kadmin/.m2/repository/org/apache/ws/commons/axiom/axiom-api/1.2.8/axiom-api-1.2.8.jar
> contains:
> <title>301 Moved Permanently</title>
> </head><body>
> <h1>Moved Permanently</h1>
> <p>The document has moved <a
> href="http://download.java.net/maven/1/org.apache.ws.commons.axiom/jars/axiom-api-1.2.8.jar">here</a>.</p>
> <hr>
> <address>Apache Server at maven-repository.dev.java.net Port 443</address>
>
> BUT, the given redirect results on the host download.java.net in 404:
>
> Not Found
> The requested object does not exist on this server. The link you
> followed is either outdated, inaccurate, or the server has been
> instructed not to let you have it.
>
> Now, I see none of the requested mirrors does provide the axiom package
> in this version 1.2.8.
> requested are: http://ws.zones.apache.org/repository2,
> http://tomcat.apache.org/dev/dist/m2-repository,
> http://repo1.maven.org/eclipse.
>
> See:
> http://ws.zones.apache.org/repository2/org/apache/ws/commons/axiom/axiom-api/1.2.8/axiom-api-1.2.8.jar
> [INFO] Unable to find resource
> 'org.apache.ws.commons.axiom:axiom-api:jar:1.2.8' in repository ws-zones
> (http://ws.zones.apache.org/repository2)
> Downloading:
> http://ws.zones.apache.org/repository2/org/apache/ws/commons/axiom/axiom-api/1.2.8/axiom-api-1.2.8.jar
> [INFO] Unable to find resource
> 'org.apache.ws.commons.axiom:axiom-api:jar:1.2.8' in repository
> apache-ws-snapshots2 (http://ws.zones.apache.org/repository2)
> Downloading:
> http://tomcat.apache.org/dev/dist/m2-repository/org/apache/ws/commons/axiom/axiom-api/1.2.8/axiom-api-1.2.8.jar
> [INFO] Unable to find resource
> 'org.apache.ws.commons.axiom:axiom-api:jar:1.2.8' in repository
> tomcat-repository (http://tomcat.apache.org/dev/dist/m2-repository)
> Downloading:
> http://repo1.maven.org/eclipse/org/apache/ws/commons/axiom/axiom-api/1.2.8/axiom-api-1.2.8.jar
> [INFO] Unable to find resource
> 'org.apache.ws.commons.axiom:axiom-api:jar:1.2.8' in repository
> eclipse-repo (http://repo1.maven.org/eclipse)
> Downloading:
> https://maven-repository.dev.java.net/nonav/repository//org.apache.ws.commons.axiom/jars/axiom-api-1.2.8.jar
> 373b downloaded  (axiom-api-1.2.8.jar)
> [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local =
> '047b09bdb4cff4f03d94f2390bc3fa79c659ec99'; remote = '<!DOCTYPE' - RETRYING
> Downloading:
> https://maven-repository.dev.java.net/nonav/repository//org.apache.ws.commons.axiom/jars/axiom-api-1.2.8.jar
> 373b downloaded  (axiom-api-1.2.8.jar)
>
> Does anyone catches this problem?
>>
>> Andreas
> Regards,
>  Patrick
>

Mime
View raw message