axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepal Jayasinghe <dee...@opensource.lk>
Subject Re: Upgrade axis2 from 1.4.1 to 1.5.1
Date Tue, 05 Jan 2010 18:22:26 GMT
This is a big issues, I think someone has broken Axis2 wsdl generation.
Could you send us the wsdl I would like to have a look.

In addition I would like to see  which POJO approach you use, if you can
try to give me a sample service to regenerate the issue.

Thanks,
Deepal

Sanjay Gupta wrote:
> Hi,
>
> I recently upgraded our app from 1.4.1 to 1.5.1 and having some issue in wsdl. I use
the POJO deployment option. I am having trouble running wsdl2java on the wsdl. I can see duplicate
entry for complex type axisConfirguation in the auto generated wsdl.  When I run wsdl2java
from 1.4.1 version of axis2 I get the error(see below). I have tried soapui and gettings errors
when I try o create a project from the wsdl. Axis2 is deployed inside tomcat 6.0.18. Any help
will be greatly appreciated. 
>
> Thanks,
>
> Sanjay
>
>
> wsdl2java -uri https://cwa024.connect4billing.com/axis2/services/ConnectSmService?wsdl
-o . -uw -or 
> Using AXIS2_HOME:   C:\axis2-1.4.1
> Using JAVA_HOME:    C:\Progra~1\Java\jdk1.6.0_13
> Retrieving document at 'https://cwa024.connect4billing.com/axis2/services/ConnectSmService?wsdl'.
> [ERROR]  Schema for namespace 'http://engine.axis2.apache.org/xsd' already contains type
'AxisConfiguration'
> org.apache.ws.commons.schema.XmlSchemaException:  Schema for namespace 'http://engine.axis2.apache.org/xsd'
already contains type 'AxisConfiguration'
> 	at org.apache.ws.commons.schema.XmlSchema.addType(XmlSchema.java:511)
> 	at org.apache.ws.commons.schema.SchemaBuilder.handleXmlSchemaElement(SchemaBuilder.java:168)
> 	at org.apache.ws.commons.schema.XmlSchemaCollection.read(XmlSchemaCollection.java:412)
> 	at org.apache.axis2.description.WSDLToAxisServiceBuilder.getXMLSchema(WSDLToAxisServiceBuilder.java:144)
> 	at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.copyExtensibleElements(WSDL11ToAxisServiceBuilder.java:2320)
> 	at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.processTypes(WSDL11ToAxisServiceBuilder.java:414)
> 	at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.processTypes(WSDL11ToAxisServiceBuilder.java:403)
> 	at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.populateService(WSDL11ToAxisServiceBuilder.java:347)
> 	at org.apache.axis2.description.WSDL11ToAllAxisServicesBuilder.populateAllServices(WSDL11ToAllAxisServicesBuilder.java:107)
> 	at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.<init>(CodeGenerationEngine.java:147)
> 	at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:35)
> 	at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:24)
>
>   

-- 
Thank you!


http://blogs.deepal.org
http://deepal.org


Mime
View raw message