axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grimm, Markus" <Gr...@juris.de>
Subject AW: archive lib directory and 3rd party libraries (axis2/tomcat 6)
Date Tue, 01 Dec 2009 16:28:40 GMT
Hi,

recently I upgraded from Axis 1.4.1 to Axis 1.5.1 and I had the same kind of problem.
I dont' know if all jars in the lib-directory of the aar-File couldn't be loaded but f.e.
a jdom.jar or a saxon8.jar wasn't loaded and under Axis2 1.4.1 everything was fine. I had
the same problems as Charles just has. So I put all the jars under axis2/WEB-INF/lib that
it works.
But I think, that's not the sense ... 

Thanks,
Markus


Von: Charles Galpin [mailto:cgalpin@lhsw.com] 
Gesendet: Dienstag, 1. Dezember 2009 16:21
An: axis-user@ws.apache.org
Betreff: Re: archive lib directory and 3rd party libraries (axis2/tomcat 6)

Hi Sameera

Here is the exception and the jar list. The exception isn't terribly telling (to me) other
than it can't find org/omg/CosNotifyFilter/InvalidGrammar which is in jacorb.jar. Once I
drop jacorb.jar under axis2/WEB-INF/lib this error goes away.

Exception in thread "LinkDIModule" java.lang.NoClassDefFoundError: org/omg/CosNotifyFilter/InvalidGrammar
        at client.corba.BaseCORBAApp.initCORBA(BaseCORBAApp.java:153)
        at client.corba.BaseCORBAService.startService(BaseCORBAService.java:100)
        at client.project.dcol.publish.corba.WebServiceDataCollectionService.webInit(WebServiceDataCollectionService.java:170
)
        at client.project.dcol.GDPI.ServiceBase$ServiceThread.run(ServiceBase.java:318)
        at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.ClassNotFoundException: org.omg.CosNotifyFilter.InvalidGrammar
        at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
        at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
        ... 5 more

Some of these are 3rd party jars and some are our own.

511Shared.jar
avalon-framework-4.1.5.jar
DetectorStationApp.jar
GDPIService.jar
jacorb.jar
joesnmp.jar
LinkDIModule.jar
logkit-1.2.jar
Shared.jar
sqljdbc4.jar

I have increased logging to debug level but don't see how to get more info than this.

thanks,
charles

On Nov 30, 2009, at 11:47 PM, Sameera Jayasoma wrote:


Hi Charles,

Its really hard to comment on this without looking at the exception log and the list of jar
files that you are putting into aar lib folder. Its better if can attached the exception log
and the name of the jar files that you using.

Thanks
Sameera
On Mon, Nov 30, 2009 at 10:36 PM, Charles Galpin <cgalpin@lhsw.com> wrote:
Does anyone have any thoughts on this? I have verified the jar file is in the lib directory
of my .aar file, and other classes and jars are loaded fine.

 

thanks,
charles

On Nov 25, 2009, at 5:49 PM, Charles Galpin wrote:

> Some jar files in my .aar lib directory do not appear to be loaded or recognized (I get
ClassNotFound exceptions).  If I put the jars in axis2/WEB-INF/lib directory they are loaded
fine.  Other jars are loaded fine so I don't think it's me putting them in the wrong place
in the .aar.
>
> Any suggestions on how to debug this?
>
> TIA,
> charles


Mime
View raw message