axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Mazza <glen.ma...@gmail.com>
Subject Re: Trouble upgrading Maven pom from Axis2 1.4.1 to 1.5.1
Date Mon, 23 Nov 2009 21:00:48 GMT

Figured it out.  The POM under Step #4 here has been updated to use Axis2
1.5.1, with either JAXB or ADB databinding: 
http://www.jroller.com/gmazza/entry/soap_client_with_axis2

Glen


Glen Mazza wrote:
> 
> No response yet.  Has anyone been able to run axis2-wsdl2code-maven-plugin
> with Axis 1.5.1?  I need to know how to upgrade my Axis2 1.4.1 pom.xml
> below to work with it.
> 
> Thanks,
> Glen
> 
> 
> Glen Mazza wrote:
>> 
>> Hello, the pom.xml for the Axis2 SOAP client below works fine with
>> axis2.version property set to 1.4.1:
>> http://www.jroller.com/gmazza/entry/soap_client_with_axis2 
>> (pom is under Step #4)
>> 
>> I'm having trouble, however, upgrading it to either Axis2 1.5 or 1.5.1. 
>> When I try axis2.version = 1.5.1, and run mvn clean install, I get the
>> following error:
>> 
>> [INFO] Internal error in the plugin manager executing goal
>> 'org.apache.axis2:axi
>> s2-wsdl2code-maven-plugin:1.5.1:wsdl2code': Unable to load the mojo
>> 'org.apache.
>> axis2:axis2-wsdl2code-maven-plugin:1.5.1:wsdl2code' in the plugin
>> 'org.apache.ax
>> is2:axis2-wsdl2code-maven-plugin'. A required class is missing:
>> org/apache/axis2
>> /wsdl/codegen/CodeGenerationException
>> org.apache.axis2.wsdl.codegen.CodeGenerationException
>> 
>> Earlier in the Maven output I get other errors such as these:
>> 
>> C:\research\zipcode>mvn install
>> [INFO] Scanning for projects...
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Building Sample SOAP Client
>> [INFO]    task-segment: [install]
>> [INFO]
>> ------------------------------------------------------------------------
>> [WARNING] POM for 'org.apache.axis2:axis2-jaxbri:pom:1.5.1:compile' is
>> invalid.
>> 
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.apache.axis2:axis2-codegen:pom:1.5.1:runtime' is
>> invalid.
>> 
>> 
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.apache.axis2:axis2-kernel:pom:1.5.1:runtime' is
>> invalid.
>> 
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.apache.axis2:axis2-adb:pom:1.5.1:runtime' is
>> invalid.
>> 
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.apache.axis2:axis2-adb-codegen:pom:1.5.1:runtime'
>> is inva
>> lid.
>> 
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.apache.axis2:axis2-java2wsdl:pom:1.5.1:runtime' is
>> invali
>> d.
>> 
>> ...
>> 
>> Any clue what the problem might be?
>> 
>> Thanks,
>> Glen
>> 
> 
> 

-- 
View this message in context: http://old.nabble.com/Trouble-upgrading-Maven-pom-from-Axis2-1.4.1-to-1.5.1-tp26402018p26485727.html
Sent from the Axis - User mailing list archive at Nabble.com.


Mime
View raw message