axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From v2cg4ss <ssel...@datamentors.com>
Subject Generated WSDL HTTPS Port not 8443
Date Thu, 05 Nov 2009 03:35:14 GMT

I have looked at other posts and nothing seems to be working, I am running
Axis2 1.5.1 with Rampart 1.5 in Tomcat 6.0.20.  When the WSDL is generated
by Axis2 from the services.xml I am getting the following:

<wsdl:service name="MyWS">
- <wsdl:port name="MyWSHttpSoap11Endpoint" binding="ns:MyWSSoap11Binding">
  <soap:address
location="http://localhost:8080/axis2/services/MyWS.MyWSHttpSoap11Endpoint/"
/> 
  </wsdl:port>
- <wsdl:port name="MyWSHttpSoap12Endpoint" binding="ns:MyWSSoap12Binding">
  <soap12:address
location="http://localhost:8080/axis2/services/MyWS.MyWSHttpSoap12Endpoint/"
/> 
  </wsdl:port>
- <wsdl:port name="MyWSHttpEndpoint" binding="ns:MyWSHttpBinding">
  <http:address
location="http://localhost:8080/axis2/services/MyWS.MyWSHttpEndpoint/" /> 
  </wsdl:port>
  </wsdl:service>

In the tomcat server.xml I access the WS via HTTPS and I have had the 8080
config parameters commented out and not commented out.  I have used
<parameter locked="false" name="modifyUserWSDLPortAddress">true</parameter>
and it still generates the WSDL with port 8080.

Is there a solution other than forcing the use of a WSDL file?
-- 
View this message in context: http://old.nabble.com/Generated-WSDL-HTTPS-Port-not-8443-tp26208367p26208367.html
Sent from the Axis - User mailing list archive at Nabble.com.


Mime
View raw message