axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vishnu Vardhan Reddy" <vre...@radiantinfo.com>
Subject RE: AXIS2 WebServices: Processing Response which does not contain SOAP Headers
Date Wed, 25 Nov 2009 11:26:31 GMT
AIXS2 version using application is  axis2-1.4.1

I am sending receiving plain/XMl (SOAP 1.1 Request and Response)

 

Problem is response from server  is plain xml it does not contain any
SOAP headers

 

Thanks,

VIshnu

 

________________________________

From: Amila Suriarachchi [mailto:amilasuriarachchi@gmail.com] 
Sent: Wednesday, November 25, 2009 4:38 PM
To: axis-user@ws.apache.org
Subject: Re: AXIS2 WebServices: Processing Response which does not
contain SOAP Headers

 

 

On Wed, Nov 25, 2009 at 4:22 PM, Vishnu Vardhan Reddy
<vreddy@radiantinfo.com> wrote:

HI ,

 

I am using AXIS2 client API to invoke third party web services. Response
we are getting from  the web service is XML but it doe contain any SOAP
headers its just plain xml file as response, but while sending request
it includes SOAP Headers .I cheeked the response though TC/IP monitor,
receiving plain XML file .Client API is giving following error while
processing the response XML SOAPProcessingException: First Element must
contain the local name, Envelope .


What is the Axis2 version you use?
What is the content type of the response? if it is application/xml the
it should process as a plain xml file.

thanks,
Amila. 

	 

	How can we force Operation client to by pass soap header
processing and getting XML file and process by AXIOM.

	 

	Thanks in advance for your kind support.

	 

	Thanks & regards,

	Vishnu.

	 

	 




-- 
Amila Suriarachchi
WSO2 Inc.
blog: http://amilachinthaka.blogspot.com/


Mime
View raw message