axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guilherme Fré <guilherme....@mowa.com.br>
Subject RES: Problems with Date objects on Axis2
Date Fri, 23 Oct 2009 12:45:28 GMT
Hi Amila,

 

I found out what was my problem. I noticed that when I use date time objects
and the Visual Studio helper for creating the client code, besides de date
time objects, bool objects are created for each one of them with the name
%nome%Specified, where %nome% is the name of the date time objects. I
discovered that if I set these bools to true, It works, but if not, the web
service receives all the date time objects as null. And this also happens
when using Calendar.

 

I’d prefer if I had not these bools. Do you have any ideas on how to
overcome this problem? 

 

De: Amila Suriarachchi [mailto:amilasuriarachchi@gmail.com] 
Enviada em: terça-feira, 20 de outubro de 2009 07:16
Para: axis-user@ws.apache.org
Assunto: Re: Problems with Date objects on Axis2

 

this[1] may help you.

Amila

[1]http://amilachinthaka.blogspot.com/2009/09/handling-date-and-datetime-wit
h-axis2.html

2009/10/19 Guilherme Fré <guilherme.fre@mowa.com.br>

Hi guys,

 

I’ve developed a WS using Axis2 and I’m trying to consume it using a C#.Net
client.

 

I have one method that require data parameters and I’m populating them with
DateTime objects from .Net. 

 

Also I have noticed that the parameter I have to set has the type
“DateTime?”. But it accepts the DateTime object as I’ve seen on debug mode.

 

So, when the request is done, the WS receives the date parameters as null.
I’ve tried to use java.util.Date and Java.sql.Timestamp and both have not
worked.

 

Does anyone can help me???

 

Thanks in regards.

--

Guilherme A. N. Fré




-- 
Amila Suriarachchi
WSO2 Inc.
blog: http://amilachinthaka.blogspot.com/


Mime
View raw message