axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshuk Pal Chaudhuri <anshukpalchaudh...@yahoo.com>
Subject Axis2 wsdl2java jibx: No mapping defined for element
Date Thu, 24 Sep 2009 22:56:36 GMT
Hello,

Mentioned an incorrect subject line in my earlier mail. My applogies.

I am trying to integrate axis2 1.5 with jibx 1.2.1. 
I am not sure that is a problem with axis2 or jibx.
I have the wsdl file and the schema with me.
I have used the jibx org.jibx.schema.codegen.CodeGen to generate the objects & the binding
file from the schema. 
I then enhance the classes using the jibx binding compiler way.Uptil now all fine.

Then when am trying to generate server side skeletons using:

org.apache.axis2.wsdl.WSDL2Java  -uri Service.wsdl -d jibx -Ebindingfile binding.xml -s -ss
-sd -scn ServiceName
referring http://ws.apache.org/axis2/1_1_1/jibx/jibx-codegen-integration.html#wsdl 
I am getting errors.

The stacktrace:

Exception in thread "main" org.apache.axis2.wsdl.codegen..CodeGenerationException
> java.lang.RuntimeException: No mapping defined for element {http://sample/types
}ElementName

I am not sure where I went wrong, also I did find it being mentioned in quite a few number
of places such as, http://marc.info/?l=axis-user&m=117028406518758&w=2 

But I really did not find any solution, I think somebody has got some workaround for this.
If I use jaxb instead of jibx, it works fine, there is not binding file in such a case, is
the generated the binding file in correct, I am not really sure so hinting at different things.
Can anyone help in some workaround.


Regards,
Anshuk



      
Mime
View raw message