axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Korn <mat...@binaervarianz.de>
Subject Re: [SOLVED but UNCLEAR] [Axis2] Including/referencing external libraries
Date Wed, 02 Sep 2009 14:03:35 GMT
Hi,

Am Wed, 02 Sep 2009 08:37:56 -0400
schrieb Deepal jayasinghe <deepalk@gmail.com>:

[Referencing external class/library]

> >     Currently I am getting something along the lines:
> > java.lang.Error: Unresolved compilation problems: The import
> > <package> cannot be resolved FooBar cannot be resolved to a type
> >
> >
> > you can also add the common jars to services/lib (you need to
> > create a lib folder)
> >
> > But this error is very strange. I should give a ClassNotFound
> > exception if it can not
> > find the class.
> Is it because some mismatching compile versions?

Yes, that seemed to be the root of the problem although I don't quite
understand it:

Both the service and the library were build with Java 1.5.0_19 on my
development machine. The service alone and the library alone (on the
command line) are running fine on the server (Java 1.6.0_07). The
combination of both does not seem to run. Why is that????

Also, shouldn't there be some form of backward compatibility for
classes compiled in java 1.5. and running on 1.6??? (I'm not very
deeply involved in this whole Java eco system...)

I now just recompiled both the service and the library on the server
and it worked.

Hope someone can clarify this for me!

Best & Thanks,
Matthias

Mime
View raw message