axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Help! Error when testing Axis2 client
Date Wed, 19 Aug 2009 18:10:36 GMT
Which classloader is the xmlbeans JAR loaded from (i.e. where is the
xmlbeans JAR located)? Idem for the TypeSystemHolder class.

Andreas

On Wed, Aug 19, 2009 at 11:43, Clara<claire_loto@yahoo.com> wrote:
>
> Hi Andreas,
> Thank you for your very helpful response. You are right, my jar files from 2
> different axis2 versions got mixed up. I was using axis2 v1.4 but i used
> axis2.jar of axis2 v1.5. The error was resolved by using axis2 v1.5.
> However, when I tried running my sample client code, I got the below error
> during runtime:
>
> [17:10:23.500] java.lang.ExceptionInInitializerError
> [17:10:23.500]  at com.sample.LoginRequestDocument$Factory
> .parse(LoginRequestDocument.java:86)
> [17:10:23.500]  at com.sample.Axis2SampleMessageR
> eceiverInOut.fromOM(Axis2SampleMessageReceiverInOut.java:2540)
> .
> .
> .
> [17:10:23.500] Caused by: java.lang.RuntimeException: Cannot load
> SchemaTypeSyst
> em. Unable to load class with name
> schemaorg_apache_xmlbeans.system.s23B9B2646D7
> 77B890CFC862E67D5196A.TypeSystemHolder. Make sure the generated binary files
> are
>  on the classpath.
> [17:10:23.500]  at
> org.apache.xmlbeans.XmlBeans.typeSystemForClassLoader(XmlBean
> s.java:783)
> [17:10:23.500]  at com.sample.LoginRequestDocument.<clinit
>>(LoginRequestDocument.java:19)
> [17:10:23.500]  ... 21 more
> [17:10:23.500] Caused by: java.lang.ClassNotFoundException:
> schemaorg_apache_xml
> beans.system.s23B9B2646D777B890CFC862E67D5196A.TypeSystemHolder
> [17:10:23.500]  at
> com.caucho.loader.DynamicClassLoader.loadClass(DynamicClassLo
> ader.java:1133)
> [17:10:23.500]  at
> com.caucho.loader.DynamicClassLoader.loadClass(DynamicClassLo
> ader.java:1113)
> [17:10:23.500]  at
> org.apache.xmlbeans.XmlBeans.typeSystemForClassLoader(XmlBean
> s.java:769)
> [17:10:23.500]  ... 22 more
> I already placed the schemaorg_apache_xml
> beans.system.s23B9B2646D777B890CFC862E67D5196A.TypeSystemHolder in the
> classpath. Is there something that I might be missing?
>
> thanks,
>
> Clara
> --- On Tue, 8/18/09, Andreas Veithen <andreas.veithen@gmail.com> wrote:
>
> From: Andreas Veithen <andreas.veithen@gmail.com>
> Subject: Re: Help! Error when testing Axis2 client
> To: axis-user@ws.apache.org
> Date: Tuesday, August 18, 2009, 2:45 AM
>
> This probably means that you have a mix of JARs from different Axis2
> versions (maybe at different locations in the class loader hierarchy).
>
> Andreas
>
>
>

Mime
View raw message