axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Ericsson <larslars9...@yahoo.com>
Subject Re: Send "raw" message
Date Mon, 13 Jul 2009 13:34:16 GMT
I'm not sure, i f i understand your problem.....
make a class with help of apache-httpclient and send your stirng to the server....
maybe you should define documentation-type and so on.....
you can look at this page to see how you can make a httpclinet with appache-httpclient.....
http://hc.apache.org/httpclient-3.x/tutorial.html this is an example to use get, but i will
recomend you to use postMethod






________________________________
From: Miha Vitorovic <mvitorovic@nil.si>
To: axis-user@ws.apache.org
Sent: Monday, July 13, 2009 2:54:37 PM
Subject: Send "raw" message


Hi all,  

While I understand that the point of
AXIS is to remove the need for generating raw XML, I would still like to
know if it is possible to do something similar to that. 

Why? Well, my deadline is approaching,
and if I don't solve the problems I'm facing, I'd like to use the option
as a workaround. 

And now the problem: I'm integrating
our in-house system with MS Dynamics CRM 4.0, and it's giving problems
that I am unable to solve with my limited knowledge of WSDL and WebSevices.
I have two messages. They both look the same (well not THE SAME, but equivalent)
to me, but the server disagrees. 

The one that is not working (generated
by axis code): 

<?xml version="1.0" encoding="UTF-8"?> 
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap..org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
  <soapenv:Header> 
    <CrmAuthenticationToken
soapenv:actor="http://schemas.xmlsoap.org/soap/actor/next"
soapenv:mustUnderstand="0" xmlns="http://schemas.microsoft.com/crm/2007/WebServices"> 
      <AuthenticationType
xmlns="http://schemas.microsoft.com/crm/2007/CoreTypes">0</AuthenticationType> 
      <OrganizationName
xmlns="http://schemas.microsoft.com/crm/2007/CoreTypes">Test</OrganizationName> 
      <CallerId xmlns="http://schemas.microsoft.com/crm/2007/CoreTypes">00000000-0000-0000-0000-000000000000</CallerId>

    </CrmAuthenticationToken> 
  </soapenv:Header> 
  <soapenv:Body> 
    <Execute xmlns="http://schemas.microsoft.com/crm/2007/WebServices"> 
      <Request xsi:type="ns1:CancelSalesOrderRequest"
xmlns:ns1="http://schemas.microsoft.com/crm/2007/WebServices"> 
        <ns1:OptionalParameters
xsi:type="ns1:OptionalParameter"/> 
        <ns1:OrderClose
xsi:type="ns1:orderclose"> 
          <ns1:salesorderid
name="salesorder" dsc="0" IsNull="false"
xsi:type="ns2:Lookup" xmlns:ns2="http://schemas.microsoft.com/crm/2006/WebServices">6dad4393-a06f-de11-bac1-007276884dce</ns1:salesorderid>

        </ns1:OrderClose> 
        <ns1:Status
xsi:type="xsd:int">-1</ns1:Status> 
      </Request> 
    </Execute> 
  </soapenv:Body> 
</soapenv:Envelope> 

The working one: 
<?xml version="1.0" encoding="utf-8"?> 
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"> 
  <soap:Header> 
    <CrmAuthenticationToken
xmlns="http://schemas.microsoft.com/crm/2007/WebServices"> 
      <AuthenticationType
xmlns="http://schemas.microsoft.com/crm/2007/CoreTypes">0</AuthenticationType> 
      <OrganizationName
xmlns="http://schemas.microsoft.com/crm/2007/CoreTypes">Test</OrganizationName> 
      <CallerId xmlns="http://schemas.microsoft.com/crm/2007/CoreTypes">00000000-0000-0000-0000-000000000000</CallerId>

    </CrmAuthenticationToken> 
  </soap:Header> 
  <soap:Body> 
    <Execute xmlns="http://schemas.microsoft.com/crm/2007/WebServices"> 
      <Request xsi:type="CancelSalesOrderRequest"> 
        <OrderClose
xsi:type="orderclose"> 
          <salesorderid
name="salesorder">6dad4393-a06f-de11-bac1-007276884dce</salesorderid> 
        </OrderClose> 
        <Status>-1</Status> 
      </Request> 
    </Execute> 
  </soap:Body> 
</soap:Envelope> 

So, can anyone help, either by making
the generated request work (point out what seems to be the problem), or
by telling me how to use the framework to send an XML generated by hand? 

Thanks in advance and best regards, 
---
 Miha Vitorovic
 Inženir v tehničnem področju
 Customer Support Engineer

  NIL Data Communications,  Tivolska cesta 48,  1000 Ljubljana,
 Slovenia
  Phone +386 1 4746 500      Fax +386 1 4746 501  
  http://www.NIL.si


      
Mime
View raw message