axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From asheikh <asad.a.she...@gmail.com>
Subject Header contains body and body contains header as well
Date Mon, 15 Jun 2009 13:07:57 GMT
Hi
I have generated a stub from a wsdl and run a test, but my problem is the
server is not returning a response. I have tcpmonitor and I saw the header
includes the body and body also includes the header.

There is another web service deployed and when I generated a stub for that
service everything is fine and using tcpmonitor I can see the header doesn't
have the body data and body/payload doesn't have the header infor,

Please help, thanks in advance.

<!----------------------------------------------------------- HEADER
----------------------------------------------------->
POST /SOAP HTTP/1.1
Content-Type: text/xml; charset=UTF-8
SOAPAction: "Sync Action"
User-Agent: Axis2
Transfer-Encoding: chunked
Host: localhost:9998

3ca
<?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="
http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header><ns1:Source></ns1:Source><ns1:Lang></ns1:Lang></soapenv:Header><soapenv:Body><ns1:
check xmlns:ns1="http://xmlns.abc.com.qb/B2B/WSDL
"><ns1:Request>QNB</ns1:Request></ns1:check></soapenv:Body></soapenv:Envelope>
0


<!-----------------------------------------------------------
BODY----------------------------------------------------->
POST /SOAP HTTP/1.1
Content-Type: text/xml; charset=UTF-8
SOAPAction: "Sync Action"
User-Agent: Axis2
Transfer-Encoding: chunked
Host: localhost:9998

3ca
<?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="
http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header><ns1:Source></ns1:Source><ns1:Lang></ns1:Lang></soapenv:Header><soapenv:Body><ns1:
check xmlns:ns1="http://xmlns.abc.com.qb/B2B/WSDL
"><ns1:Request>QNB</ns1:Request></ns1:check></soapenv:Body></soapenv:Envelope>
0

Mime
View raw message