axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Salisbury, Mark" <mark.salisb...@hp.com>
Subject RE: maven build error "Plugin's descriptor contains the wrong version: SNAPSHOT"
Date Wed, 29 Apr 2009 20:31:44 GMT
Thanks, I actually tried that (I saw a post on another thread that suggested building those
modules first).  I still got the same error after a successful "mvn install" of those modules.

Mark

-----Original Message-----
From: Sagara Gunathunga [mailto:sagara.gunathunga@gmail.com] 
Sent: Wednesday, April 29, 2009 2:07 PM
To: axis-user@ws.apache.org
Subject: Re: maven build error "Plugin's descriptor contains the wrong version: SNAPSHOT"

Hi Mark,
Before you build the  top level Axis2 project move to following two
modules and try to build them first , after that you can build the
Axis2 project with Maven. Hope this will work.

1. axis2-aar-maven-plugin
2. axis2-mar-maven-plugin


Thanks,

On Thu, Apr 30, 2009 at 12:34 AM, Salisbury, Mark <mark.salisbury@hp.com> wrote:
> Hello,
>
>
>
> I’m unable to build Axis 2 java from source.
>
>
>
> I downloaded SVN version 768341 from
> http://svn.apache.org/repos/asf/webservices/axis2/trunk.
>
>
>
> Then I followed instructions on the install guide
> (http://ws.apache.org/axis2/1_4_1/installationguide.html), and installed
> Maven from http://maven.apache.org/download.html.
>
>
>
> Any suggestions on why I might be seeing this error are appreciated.
>
>
>
> Mark
>
>
>
> Here’s my build log:
>
>
>
> D:\yoda\axis2\java>mvn install
>
> [INFO] Scanning for projects...
>
> [INFO] Reactor build order:
>
> [INFO]   Apache Axis2 - Parent
>
> [INFO]   Apache Axis2 - Kernel
>
> [INFO]   Apache Axis2 - Data Binding
>
> [INFO]   Apache Axis2 - Transport - Local
>
> [INFO]   Apache Axis2 - Transport - HTTP
>
> [INFO]   Apache Axis2 - Code Generation
>
> [INFO]   Apache Axis2 - ADB Codegen
>
> [INFO]   Apache Axis2 - tool - MAR Maven Plugin
>
> [INFO]   Apache Axis2 - Addressing
>
> [INFO]   Apache Axis2 - Java2WSDL
>
> [INFO]   Apache Axis2 - Fast Infoset
>
> [INFO]   Apache Axis2 - Clustering
>
> [INFO]   Apache Axis2 - Scripting
>
> [INFO]   Apache Axis2 - JAXB-RI Data Binding
>
> [INFO]   Apache Axis2 - SAAJ
>
> [INFO]   Apache Axis2 - Metadata
>
> [INFO]   Apache Axis2 - JAXWS
>
> [INFO]   Apache Axis2 - JAXWS Integration Tests
>
> [INFO]   Apache Axis2 - JiBX Data Binding
>
> [INFO]   Apache Axis2 - JSON
>
> [INFO]   Apache Axis2 - MTOM Policy
>
> [INFO]   Apache Axis2 - spring
>
> [INFO]   Apache Axis2 - OSGi Integration
>
> [INFO]   Apache Axis2 - XMLBeans Data Binding
>
> [INFO]   Apache Axis2 - Integration
>
> [INFO]   Apache Axis2 - MEX
>
> [INFO]   Apache Axis2 - MTOM Policy module
>
> [INFO]   Apache Axis2 - Ping
>
> [INFO]   Apache Axis2 - tool - AAR Maven Plugin
>
> [INFO]   Apache Axis2 - Version Service
>
> [INFO]   Apache Axis2 - SOAP Monitor
>
> [INFO]   Apache Axis2 - tool - Ant Plugin
>
> [INFO]   Apache Axis2 - Root
>
> [INFO]   Apache Axis2 - tool - Eclipse Codegen Plugin
>
> [INFO]   Apache Axis2 - tool - Eclipse service Plugin
>
> [INFO]   Apache Axis2 - tool - Intellij IDEA Plugin
>
> [INFO]   Apache Axis2 - tool - Java2WSDL Maven Plugin
>
> [INFO]   Apache Axis2 - tool - WSDL2Code Maven Plugin
>
> [INFO]   Apache Axis2 - CORBA
>
> [INFO]   Apache Axis2 - JAXWS (mar)
>
> [INFO]   Apache Axis2 - Web Application module
>
> [INFO]   Apache Axis2 - Samples
>
> Downloading:
> http://ws.zones.apache.org/repository2/org/apache/felix/maven-bundle-plugin/1.4.0/maven-bundle-plugin-1.4.0.pom
>
> [INFO] Unable to find resource
> 'org.apache.felix:maven-bundle-plugin:pom:1.4.0' in repository ws-zones
> (http://ws.zones.apache.org/repository2)
>
> Downloading:
> http://repo1.maven.org/maven2/org/apache/felix/maven-bundle-plugin/1.4.0/maven-bundle-plugin-1.4.0.pom
>
> 4K downloaded  (maven-bundle-plugin-1.4.0.pom)
>
> Downloading:
> http://ws.zones.apache.org/repository2/org/apache/felix/felix/1.0.2/felix-1.0.2.pom
>
> [INFO] Unable to find resource 'org.apache.felix:felix:pom:1.0.2' in
> repository ws-zones (http://ws.zones.apache.org/repository2)
>
> Downloading:
> http://repo1.maven.org/maven2/org/apache/felix/felix/1.0.2/felix-1.0.2.pom
>
> 13K downloaded  (felix-1.0.2.pom)
>
> Downloading:
> http://ws.zones.apache.org/repository2/org/apache/felix/maven-bundle-plugin/1.4.0/maven-bundle-plugin-1.4.0.jar
>
> [INFO] Unable to find resource
> 'org.apache.felix:maven-bundle-plugin:maven-plugin:1.4.0' in repository
> ws-zones (http://ws.zones.apache.org/repository2)
>
> Downloading:
> http://repo1.maven.org/maven2/org/apache/felix/maven-bundle-plugin/1.4.0/maven-bundle-plugin-1.4.0.jar
>
> 134K downloaded  (maven-bundle-plugin-1.4.0.jar)
>
> [INFO] snapshot org.apache.axis2:axis2-mar-maven-plugin:SNAPSHOT: checking
> for updates from apache-snapshots
>
> [INFO] snapshot org.apache.axis2:axis2-mar-maven-plugin:SNAPSHOT: checking
> for updates from ws-zones
>
> Downloading:
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/axis2/axis2-mar-maven-plugin/SNAPSHOT/axis2-mar-maven-plugin-20090424.213913-2417.jar
>
> 17K downloaded  (axis2-mar-maven-plugin-20090424.213913-2417.jar)
>
> [INFO]
> ------------------------------------------------------------------------
>
> [ERROR] BUILD ERROR
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] Internal error in the plugin manager getting plugin
> 'org.apache.axis2:axis2-mar-maven-plugin': Plugin
> 'org.apache.axis2:axis2-mar-maven-plugin:20090424.213913-2417' has an
> invalid descriptor:
>
> 1) Plugin's descriptor contains the wrong version: SNAPSHOT
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] For more information, run Maven with the -e switch
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] Total time: 7 seconds
>
> [INFO] Finished at: Fri Apr 24 16:01:11 MDT 2009
>
> [INFO] Final Memory: 9M/16M
>
> [INFO]
> ------------------------------------------------------------------------
>
> D:\yoda\axis2\java>mvn -e install
>
> + Error stacktraces are turned on.
>
> [INFO] Scanning for projects...
>
> [INFO] Reactor build order:
>
> [INFO]   Apache Axis2 - Parent
>
> [INFO]   Apache Axis2 - Kernel
>
> [INFO]   Apache Axis2 - Data Binding
>
> [INFO]   Apache Axis2 - Transport - Local
>
> [INFO]   Apache Axis2 - Transport - HTTP
>
> [INFO]   Apache Axis2 - Code Generation
>
> [INFO]   Apache Axis2 - ADB Codegen
>
> [INFO]   Apache Axis2 - tool - MAR Maven Plugin
>
> [INFO]   Apache Axis2 - Addressing
>
> [INFO]   Apache Axis2 - Java2WSDL
>
> [INFO]   Apache Axis2 - Fast Infoset
>
> [INFO]   Apache Axis2 - Clustering
>
> [INFO]   Apache Axis2 - Scripting
>
> [INFO]   Apache Axis2 - JAXB-RI Data Binding
>
> [INFO]   Apache Axis2 - SAAJ
>
> [INFO]   Apache Axis2 - Metadata
>
> [INFO]   Apache Axis2 - JAXWS
>
> [INFO]   Apache Axis2 - JAXWS Integration Tests
>
> [INFO]   Apache Axis2 - JiBX Data Binding
>
> [INFO]   Apache Axis2 - JSON
>
> [INFO]   Apache Axis2 - MTOM Policy
>
> [INFO]   Apache Axis2 - spring
>
> [INFO]   Apache Axis2 - OSGi Integration
>
> [INFO]   Apache Axis2 - XMLBeans Data Binding
>
> [INFO]   Apache Axis2 - Integration
>
> [INFO]   Apache Axis2 - MEX
>
> [INFO]   Apache Axis2 - MTOM Policy module
>
> [INFO]   Apache Axis2 - Ping
>
> [INFO]   Apache Axis2 - tool - AAR Maven Plugin
>
> [INFO]   Apache Axis2 - Version Service
>
> [INFO]   Apache Axis2 - SOAP Monitor
>
> [INFO]   Apache Axis2 - tool - Ant Plugin
>
> [INFO]   Apache Axis2 - Root
>
> [INFO]   Apache Axis2 - tool - Eclipse Codegen Plugin
>
> [INFO]   Apache Axis2 - tool - Eclipse service Plugin
>
> [INFO]   Apache Axis2 - tool - Intellij IDEA Plugin
>
> [INFO]   Apache Axis2 - tool - Java2WSDL Maven Plugin
>
> [INFO]   Apache Axis2 - tool - WSDL2Code Maven Plugin
>
> [INFO]   Apache Axis2 - CORBA
>
> [INFO]   Apache Axis2 - JAXWS (mar)
>
> [INFO]   Apache Axis2 - Web Application module
>
> [INFO]   Apache Axis2 - Samples
>
> [INFO]
> ------------------------------------------------------------------------
>
> [ERROR] BUILD ERROR
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] Internal error in the plugin manager getting plugin
> 'org.apache.axis2:axis2-mar-maven-plugin': Plugin
> 'org.apache.axis2:axis2-mar-maven-plugin:20090424.213913-2417' has an
> invalid
>
> descriptor:
>
> 1) Plugin's descriptor contains the wrong version: SNAPSHOT
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] Trace
>
> org.apache.maven.lifecycle.LifecycleExecutionException: Internal error in
> the plugin manager getting plugin 'org.apache.axis2:axis2-mar-maven-plugin':
> Plugin 'org.apache.axis2:axis2-mar-maven-plugin:20090424.213913-2417' has an
> invalid descriptor:
>
> 1) Plugin's descriptor contains the wrong version: SNAPSHOT
>
>         at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1521)
>
>         at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlers(DefaultLifecycleExecutor.java:1434)
>
>         at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:218)
>
>         at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:179)
>
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
>
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
>
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:356)
>
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
>         at java.lang.reflect.Method.invoke(Method.java:597)
>
>         at
> org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>
>         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>
>         at
> org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>
>         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>
> Caused by: org.apache.maven.plugin.PluginManagerException: Plugin
> 'org.apache.axis2:axis2-mar-maven-plugin:20090424.213913-2417' has an
> invalid descriptor:
>
> 1) Plugin's descriptor contains the wrong version: SNAPSHOT
>
>         at
> org.apache.maven.plugin.DefaultPluginManager.addPlugin(DefaultPluginManager.java:323)
>
>         at
> org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:217)
>
>         at
> org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:177)
>
>         at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1517)
>
>         ... 14 more
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] Total time: < 1 second
>
>
>
>
>
>



-- 
Sagara Gunathunga

Blog - http://ssagara.blogspot.com
Web - http://sagaras.awardspace.com/
Mime
View raw message