axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Weng Lock Mok <wengl...@ninervictor.com>
Subject Axis 1.4 & Tomcat 5.5 - Problem deploying web application
Date Sat, 04 Apr 2009 12:22:52 GMT
Hi everyone,

I am currently running Tomcat 5.5 and JDK 1.4.2 with Axis 1.4 as the  
WS platform.  I am encountering some problems with deploying the web  
service, as it does not seem to deploy correctly, instead outputting  
the following error message...

$ java org.apache.axis.client.AdminClient com/travelService/ws/ 
airlineBooking/deploy.wsdd
Processing file com/travelService/ws/airlineBooking/deploy.wsdd
Exception: AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/ 
envelope/}Server.userException
faultSubcode:
faultString: java.lang.reflect.InvocationTargetException
faultActor:
faultNode:
faultDetail:
	{http://xml.apache.org/axis/}hostname: localhost:8080

The WSDL and XSD files are generated by myself, and I used the  
WSDL2Java tool to generate the server-side skeleton and the client  
side stubs.

I also noticed that WSDL2Java made a small note about "Unrecognized  
style = 'null'", does anybody happen to know what that means?

My WSDL file is as follows -

==== airlineBooking.wsdl ====

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
	xmlns:tns="http://travelService.com/ws/airlineBooking/"
	xmlns:schema="http://travelService.com/ws/airlineBooking/"
	xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
	xmlns:xsd="http://www.w3.org/2001/XMLSchema" name="airlineBooking"
	xmlns:m="http://travelService.com/message/airlineBooking/"
	targetNamespace="http://travelService.com/ws/airlineBooking/">
	<wsdl:types>
		<xsd:schema
			targetNamespace="http://travelService.com/message/airlineBooking/"
			xmlns:xsd="http://www.w3.org/2001/XMLSchema"
			xmlns:tns="http://travelService.com/message/airlineBooking/"
			xmlns:r="http://travelService.com/resource">
			<!-- importing all the xml schema definitions created earlier -->
			<xsd:import
				namespace="http://travelService.com/resource"
				schemaLocation="booking.xsd" />
				
			<xsd:include schemaLocation="bookRequest.xsd" />
			<xsd:include schemaLocation="bookResponse.xsd" />	
			<xsd:include schemaLocation="bookError.xsd" />	
		</xsd:schema>
	</wsdl:types>
	
	<!-- defines the message parameters for the input to the book  
operation -->
	<wsdl:message name="bookInput">
		<wsdl:part element="m:bookRequest" name="request" />
	</wsdl:message>
	
	<!-- defines the message parameters for the output from the book  
operation -->
	<wsdl:message name="bookOutput">
		<wsdl:part element="m:bookResponse" name="response" />
	</wsdl:message>
	
	<!-- defines the message parameters for the fault message if no  
availability is found -->
	<wsdl:message name="noAvailabilityMessage">
		<wsdl:part element="m:bookError" name="noAvailResponse" />
	</wsdl:message>
	
	<wsdl:portType name="AirlineBooking">
		<wsdl:operation name="book">
			<wsdl:input message="tns:bookInput" />
			<wsdl:output message="tns:bookOutput" />
			<wsdl:fault name="NoAvailabilityFault"  
message="tns:noAvailabilityMessage" />
		</wsdl:operation>
	</wsdl:portType>
	
	<wsdl:binding name="airlineBookingSOAPBinding"  
type="tns:AirlineBooking">
		<soap:binding style="document"
			transport="http://schemas.xmlsoap.org/soap/http" />
		<wsdl:operation name="book">
			<soap:operation
				soapAction="http://localhost:8080/axis/services/airlineBooking/ 
book" />
			<wsdl:input>
				<soap:body use="literal" parts="request" />
			</wsdl:input>
			<wsdl:output>
				<soap:body use="literal" parts="response" />
			</wsdl:output>
			<wsdl:fault name="NoAvailabilityFault">
				<soap:fault name="noAvailabilityMessage" />
			</wsdl:fault>
		</wsdl:operation>
	</wsdl:binding>
	
	<wsdl:service name="AirlineBooking">
		<wsdl:port binding="tns:airlineBookingSOAPBinding"  
name="airlineBookingSOAPBinding">
			<soap:address location="http://localhost:8080/axis/services/airlineBooking 
" />
		</wsdl:port>
	</wsdl:service>
	
</wsdl:definitions>

==== end of fie ====

I'm not quite sure what is going on, I have been tweaking the wsdl  
files for about 2 days now and nothing seems remotely close to solving  
the problem.

I would really be very appreciative for any help you can render.   
Thank you very much in advance!

Cheers,
WengLock.

Mime
View raw message