axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: Axis2 Codegen Wizard
Date Sun, 15 Mar 2009 13:55:27 GMT

if you can provide the class we can determine this is error is eclipse-plugin problem
or Java2WSDL
also I prefer to create my .project and .classpath from within eclipse environment
after downloading 'blessed' plugins 

thanks,
Martin 
______________________________________________ 
Disclaimer and confidentiality note 
Everything in this e-mail and any attachments relates to the official business of Sender.
This transmission is of a confidential nature and Sender does not endorse distribution to
any party other than intended recipient. Sender does not necessarily endorse content contained
within this transmission. 




Date: Sun, 15 Mar 2009 08:06:01 -0400
From: mtarullo463@optonline.net
Subject: Re: Axis2 Codegen Wizard
To: axis-user@ws.apache.org








Thamizhannal,
 
Thank you for your suggestions, particularly the 
java2wsdl command line tool.  I will certainly give this a try as I 
urgently need to create the WSDL for my next project release.
 
As for my Java Build Path it currently contains the 
following libraries:
MySQL Connector Jar File
Apache Tomcat v5.5
EAR Libraries
Java System Library JDK v1.6.0
Web App Libraries (which contains a number of Axis2 
jar files)
 
I noticed that the stax-api jar file that had to be 
added into the Axis2 Codegen Wizard lib folder under the Eclipse plugins was not 
listed as one of the jar files under Web App Libraries.  I might attempt to 
add this jar file to the build path and see if that helps since it was one of 
the files mentioned in the solution I tried.  Also, there are various 
versions of this solution, some say to use the stax-api-1.0.1.jar others say to 
use the geronimo-stax-api_1.1_spec-1.0.1.jar.  I have tried both and 
neither work.  Can you, or any one else, comment on which is the correct 
file of the two?
 
As for the ~\bin folder, after entering the fully 
qualified class name I click the Add Folder button and add the path to my 
projects build folder and the sub-folder under it that contains the class file I 
am trying to generate WSDL for.  BTW, I have also tried Add Jar button and 
pointed the tool to a jar file I created for my project.  This did not work 
either.
 
Mike

  ----- Original Message ----- 
  From: 
  Thamizh 
  
  To: axis-user@ws.apache.org 
  Sent: Sunday, March 15, 2009 2:40 
AM
  Subject: Re: Axis2 Codegen Wizard
  

  
    
    
      Mike,

Ensure that you have added all the necessary 
        Axis library jar files and supporting jar files to compile your Java 
        source code in Java Build Path. If so this would not show this 
        ClassNotFound error.

Also check while adding the class folder 
        name Have you added the project's bin directory. Hope this would resolve 
        your problem.

If none of the suggestion were resolving your 
        problem then use command line utility Java2WSDL to generate 
        Java2WSDL.

Regards,
Thamizhannal P

--- On Sun, 
        15/3/09, Michael <mtarullo463@optonline.net> wrote:

        
From: 
          Michael <mtarullo463@optonline.net>
Subject: Re: Axis2 
          Codegen Wizard
To: axis-user@ws.apache.org
Date: Sunday, 15 
          March, 2009, 8:55 AM


          
          

          Martin,
           
          First, thank you for your reply.
           
          I most certainly can supply the 
          source.
           
          Do you need just the class that I am try to 
          generate the WSDL for, supporting classes or the entire 
          project?
           
          Let me know and I'll get it to you right 
          away.
           
          Mike
          
            ----- 
            Original Message ----- 
            From: 
            Martin Gainty 
            To: 
            axis-user@ws.apache.org 
            
            Sent: 
            Saturday, March 14, 2009 9:59 PM
            Subject: 
            RE: Axis2 Codegen Wizard
            
Mike-

can you Include the java class contents 
            so we can test it here?

thanks,
Martin 
            
______________________________________________ 
Disclaimer 
            and confidentiality note 
Everything in this e-mail and any 
            attachments relates to the official business of Sender. This 
            transmission is of a confidential nature and Sender does not endorse 
            distribution to any party other than intended recipient. Sender does 
            not necessarily endorse content contained within this transmission. 
            





            
            Date: Sat, 14 Mar 2009 18:06:21 -0400
From: 
            mtarullo463@optonline.net
Subject: Axis2 Codegen Wizard
To: 
            axis-user@ws.apache.org


            

            I am having a problem generating a WSDL 
            file from my Java code.
             
            The Java source/classpath selection 
            page of the Axis2 Codegen Wizard appears to have several 
            bugs.
             
            1) when I enter the fully qualified 
            class name an error message stating that the class name is not 
            properly terminated is displayed; even after I finish entering the 
            fully quilified name the error message remains 
displayed
             
            2) after adding the folder containing 
            the class files and clicking the Test Class Loading button I get an 
            error message that says a java.lang.ClassNotFoundException was 
            thrown
             
            Is there a fix for this?
             
            I have added the stax-api-1.0.1.jar and 
            backport-util-concurrent-3.1.jar file to the Axis2 Codegen Wizard 
            \lib folder in Eclipse\plugins.  This did not solve the problem 
            for me.
             
            This fix was for a target invocation 
            exception, if I recall.  Is this all related to the same 
            problem or are there two different problems here?
             
            Any workarounds until this gets 
            fixed?  Is using Maven2 an alternative?
             
            Any help would be greatly 
            appreciated.
             
            BTW: I'm using Eclipse 
            Ganymede(v3.4.1), Axis2 v1.4.1 and Axis2 Codegen Wizard 
            v1.3.0

            
            Windows Liveā„¢ Contacts: Organize your contact list. Check it out. 
            

            

            

No virus found in this incoming message.
Checked by 
            AVG - www.avg.com 
Version: 8.0.237 / Virus Database: 
            270.11.13/2001 - Release Date: 03/14/09 
        06:54:00


  
  Connect with friends all over the world. Get 
  Yahoo! India Messenger.
  
  


  

No virus found in this incoming message.
Checked by AVG - 
  www.avg.com 
Version: 8.0.237 / Virus Database: 270.11.13/2001 - Release 
  Date: 03/14/09 06:54:00

_________________________________________________________________
Express your personality in color! Preview and select themes for HotmailĀ®. 
http://www.windowslive-hotmail.com/LearnMore/personalize.aspx?ocid=TXT_MSGTX_WL_HM_express_032009#colortheme
Mime
View raw message