axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From izzybitsie <isid...@juno.com>
Subject tar/untar aar file strange result - config file not found
Date Sun, 08 Feb 2009 03:26:06 GMT

Hi,
I created an Axis2 WS and  deployed in Tomcat as an aar file without problem
(HP-UX and Linux - gentoo). Tested service with various clients without
problem either. Service was created using wsdl2java and filling in the
business logic
Business logic codes reads Properties from a config file included in aar
pack in a subdirectory named resources. This is a subdirectory of the
directory in which all classes are stored.
I decided to create a tar file with the aar file and the installation
programs. (tar cfM mydir.tar mydir)
I copy this file to a different path in the same host where the service is
working. The installation script modifies the aar package config file with
info entered by the installer and it then deploys the service. When the
client program runs, I get the "config file is not found.".
However, when I check the contents of the aar file the config file is
exactly in the same path as it was originally and its contents reflect the
info entered by installer.
I don't see anything wrong in any of the Tomcat log files.  I have tried
several times with same result in all cases.

Could anyone help me figure out what am I doing wrong?
THANKS
-- 
View this message in context: http://www.nabble.com/tar-untar-aar-file-strange-result---config-file-not-found-tp21895543p21895543.html
Sent from the Axis - User mailing list archive at Nabble.com.


Mime
View raw message