axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghu Upadhyayula" <rupadhyay...@responsys.com>
Subject RE: listServices issue
Date Thu, 18 Dec 2008 18:48:13 GMT
Hi Shah,

	The listServices will only work if you have the axis2-web folder
which comes with the Axis2 webapp in your war at the same level of
WEB-INF, because the listServices functionality in AxisServlet is
referring a jsp file (listServices.jsp) which is inside axis2-web
folder.

Thanks
Raghu

-----Original Message-----
From: Shah Asrani [mailto:shahasrani@gmail.com] 
Sent: Thursday, December 18, 2008 11:19 AM
To: axis-user@ws.apache.org
Subject: Re: listServices issue

yes, I must have missed something. I can even do ?wsdl on the service
and get wsdl.  really weird. I will try do some more debugging and may
be I can find out what is wrong.

On Thu, Dec 18, 2008 at 11:40 AM, Deepal jayasinghe <deepalk@gmail.com>
wrote:
> Shah Asrani wrote:
>> I have deployed a web service dynamically in Axis2.  The web service
>> works fine.  When client make a call, web service is found and a
>> response is returned.  However, if I use the url to list the
services,
>> it returns nothing:
>> http://localhost:8080/<mycontext>/services/listServices
> it is weird  :), if you can access the service then it should be list
under the available services. May be you have missed something.
>
> Deepal
>
>> Any Ideas?
>>
>> Shah Asrani
>>
>>
>
>
> --
> Thank you!
>
>
> http://blogs.deepal.org
> http://deepal.org
>
>

Mime
View raw message